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This document describes the following software options:

● R&S®SMW-K40/-K41
1413.3684.xx, 1413.3732.xx

This manual describes firmware version FW 4.70.026.xx and later of the R&S®SMW200A.
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1  Preface

1.1  Documentation Overview

This section provides an overview of the R&S SMW user documentation. Unless speci-
fied otherwise, you find the documents on the R&S SMW product page at:

www.rohde-schwarz.com/manual/smw200a

1.1.1  Getting Started Manual

Introduces the R&S SMW and describes how to set up and start working with the prod-
uct. Includes basic operations, typical measurement examples, and general informa-
tion, e.g. safety instructions, etc. A printed version is delivered with the instrument.

1.1.2  User Manuals and Help

Separate manuals for the base unit and the software options are provided for down-
load:
● Base unit manual

Contains the description of all instrument modes and functions. It also provides an
introduction to remote control, a complete description of the remote control com-
mands with programming examples, and information on maintenance, instrument
interfaces and error messages. Includes the contents of the getting started manual.

● Software option manual
Contains the description of the specific functions of an option. Basic information on
operating the R&S SMW is not included.

The contents of the user manuals are available as help in the R&S SMW. The help
offers quick, context-sensitive access to the complete information for the base unit and
the software options.

All user manuals are also available for download or for immediate display on the Inter-
net.

1.1.3  Tutorials

The R&S SMW provides interactive examples and demonstrations on operating the
instrument in form of tutorials. A set of tutorials is available directly on the instrument.

Documentation Overview

http://www.rohde-schwarz.com/manual/smw200a
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1.1.4  Service Manual

Describes the performance test for checking the rated specifications, module replace-
ment and repair, firmware update, troubleshooting and fault elimination, and contains
mechanical drawings and spare part lists.

The service manual is available for registered users on the global Rohde & Schwarz
information system (GLORIS, https://gloris.rohde-schwarz.com).

1.1.5  Instrument Security Procedures

Deals with security issues when working with the R&S SMW in secure areas. It is avail-
able for download on the Internet.

1.1.6  Basic Safety Instructions

Contains safety instructions, operating conditions and further important information.
The printed document is delivered with the instrument.

1.1.7  Data Sheets and Brochures

The data sheet contains the technical specifications of the R&S SMW. It also lists the
options and their order numbers and optional accessories.

The brochure provides an overview of the instrument and deals with the specific char-
acteristics.

See www.rohde-schwarz.com/brochure-datasheet/smw200a

1.1.8  Release Notes and Open Source Acknowledgment (OSA)

The release notes list new features, improvements and known issues of the current
firmware version, and describe the firmware installation.

The open source acknowledgment document provides verbatim license texts of the
used open source software.

See www.rohde-schwarz.com/firmware/smw200a

1.1.9  Application Notes, Application Cards, White Papers, etc.

These documents deal with special applications or background information on particu-
lar topics.

See www.rohde-schwarz.com/application/smw200a and www.rohde-schwarz.com/
manual/smw200a

Documentation Overview

https://gloris.rohde-schwarz.com
http://www.rohde-schwarz.com/brochure-datasheet/smw200a
http://www.rohde-schwarz.com/firmware/smw200a
http://www.rohde-schwarz.com/application/smw200a
http://www.rohde-schwarz.com/manual/smw200a
http://www.rohde-schwarz.com/manual/smw200a
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2  Welcome to the GSM/EDGE and EDGE
Evolution Digital Standard
The R&S SMW-K40 is a firmware application that adds functionality to generate sig-
nals in accordance with the GSM/EDGE standard, based on the GMSK and 8PSK
modulation. Option R&S SMW-K41 EDGE Evolution extends the GSM/EDGE signal
generation with simulation of higher order modulations (QPSK, 16QAM and 32QAM)
for higher symbol rate bursts and higher order modulations (16QAM and 32QAM) for
normal symbol rate bursts.

The R&S SMW-K40 features:
● Generation of all GSM variants. There is no restriction regarding the use of GSM

slots, EDGE slots and EDGE Evolution slots.
● Generation of both the transmitter signal of a base station (BS) and the transmitter

signal of user equipment (UE).
● Configuration of all kind of GSM/EDGE data bursts Normal (full rate and half rate)

and EDGE; control bursts Access, Frequency Correction and Synchronization; a
Dummy Burst; and bursts for test purposes, All_Data (GSM and EDGE).

● Generation of half rate slots and multi slots for HSCSD (high speed circuit switched
data) and (E)GPRS (general packet radio service) configurations at the physical
level.
Allocation of multiple slots to a single connection (channel banding).

● Three configuration modes for each the normal and the higher symbol rate mode:
unframed, frame (single) and frame (double)

The R&S SMW-K41 features:
● Generation of burst types defined for normal symbol rate and higher order modula-

tion schemes such as the data burst Normal (16QAM and 32QAM) and All_Data
(16QAM and 32QAM) as well as with the burst types defined for higher symbol
rates HSR (QPSK, 16QAM and 32QAM) and HSR All_Data (QPSK, 16QAM and
32QAM).

● Configuration and generation of burst for VAMOS operation. Available are All_Data
(AQPSK) and Normal (AQPSK) bursts for full and half rate operation.

For more information, see data sheet.

This user manual contains a description of the functionality that the application pro-
vides, including remote control operation.

All functions not discussed in this manual are the same as in the base unit and are
described in the R&S SMW user manual. The latest version is available at:

www.rohde-schwarz.com/manual/SMW200A

Installation

You can find detailed installation instructions in the delivery of the option or in the
R&S SMW service manual.

https://www.rohde-schwarz.com/manual/smw200a
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2.1  Accessing the GSM/EDGE Dialog

To open the dialog with GSM/EDGE settings

► In the block diagram of the R&S SMW, select "Baseband > GSM/EDGE".

A dialog box opens that displays the provided general settings.

The signal generation is not started immediately. To start signal generation with the
default settings, select "State > On".

2.2  Scope

Tasks (in manual or remote operation) that are also performed in the base unit in the
same way are not described here.
In particular, it includes:
● Managing settings and data lists, like storing and loading settings, creating and

accessing data lists, or accessing files in a particular directory.
● Information on regular trigger, marker and clock signals and filter settings, if appro-

priate.
● General instrument configuration, such as checking the system configuration, con-

figuring networks and remote operation
● Using the common status registers

For a description of such tasks, see the R&S SMW user manual.

2.3  Notes on Screenshots

When describing the functions of the product, we use sample screenshots. These
screenshots are meant to illustrate as many as possible of the provided functions and
possible interdependencies between parameters. The shown values may not represent
realistic usage scenarios.

The screenshots usually show a fully equipped product, that is: with all options instal-
led. Thus, some functions shown in the screenshots may not be available in your par-
ticular product configuration.

Notes on Screenshots
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3  About the GSM/EDGE Options

3.1  Required Options

The basic equipment layout for generating GSM/EDGE signals includes the options:
● Standard or wideband baseband generator (R&S SMW-B10/-B9)
● Baseband main module (R&S SMW-B13) or wideband baseband main module

(R&S SMW-B13XT)
● Option GSM/EDGE (R&S SMW-K40)
● Option EDGE evolution (R&S SMW-K41)
● Frequency option (e.g. R&S SMW-B1003)
● Option fading simulation (R&S SMW-B14) for the sumulation of VAMOS jitter

To play back a signal from a waveform file created by the simulation software
R&S WinIQSIM2, the corresponding R&S WinIQSIM2 digital standard option must be
installed.

For more information, see data sheet.

3.2  GSM/EDGE

GSM is a TDMA standard for cellular mobile radio networks.

Every TDMA frame consists of eight timeslots (or simply "slots"). Each slot can be sep-
arately turned on or off. A maximum of seven different level attenuation values can be
defined and allocated separately to the eight slots independently of one another.

To configure a slot, it is necessary to define a burst type. Different burst types are avail-
able, depending on the installed options. Available are burst types defined for normal
symbol rate and higher-order modulation schemes and with the burst types defined for
higher symbol rates HSR.

Higher symbol rates are achieved by reduction of the symbol period and employing of
higher symbol rate bursts (HB) instead of the normal burst (NB). A normal burst con-
tains 116 encrypted symbols and uses timeslots with normal duration (156 or 157 sym-
bols long). The higher symbol rate bursts carry information on full rate packet traffic
channels, contain 138 encrypted symbols and use timeslots with reduced symbol dura-
tion (187 or 188 symbols long).

The modulation data is continuously inserted into the chosen slots (in real time). In this
fashion, the data generator uses a digital signal processor to generate a data stream
complete with modulation data and control signals for power ramping.

This data stream is converted into I/Q signals in the modulation encoder.

GSM/EDGE
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The R&S SMW processes the signal depending on the configured modulation scheme
and selected symbol rate mode:
● In accordance with the GSM standard, the MSK modulation type is set by default to

a symbol rate of 270.833 ksymb/s and gauss filtering.
You can adjust the symbol rate. Also, you can use an FSK modulation with configu-
rable span.

● In accordance with the standard, the EDGE slots use 8PSK modulation type with
3/8 rotation at a symbol rate of 270.833 ksymb/s and gauss linearized filtering.

● In accordance to EDGE evolution specifications (option R&S SMW-K41), the
EDGE evolution slots in a normal burst (NB) are 16QAM or 32QAM modulated.
They use a symbol rate of 270.833 ksymb/s and are gauss linearized filtered. The
EDGE evolution slots in higher symbol rate bursts (HB) are QPSK, 16QAM or
32QAM modulated. They use a symbol rate of 325 ksymb/s and are spectrally nar-
row or wide pulse shape filtered.

● In accordance to VAMOS specifications (option R&S SMW-K41), the slots are
AQPSK modulated at a symbol rate of 270.833 ksymb/s and gauss linearized filter-
ing.

You can configure the GSM/EDGE signal in on of the following modes:
● Mode unframed - a signal with standard-compliant modulation parameters but

without slot and frame structure is generated.
● Mode frame (single) - a signal consisting of a frame is generated; it is also possi-

ble to choose half rate bursts and to define multi-slots.
● Mode frame (double) - a signal consisting of two frames is generated; the frames

are repeated according to a defined default.

3.3  VAMOS (Voice services over Adaptive Multi-User
channels on One Slot)

According to 3GPP TS 45.001, with VAMOS it is possible to serve two MS simultane-
ously on the same physical resource. Thus the voice channel capacity in the CS
domain can be doubled.

Each of the two VAMOS users is assigned a so-called VAMOS subchannel, i.e. the
physical radio resource is split into two subchannels, one for each VAMOS user. The
two subchannels are separated in uplink and downlink via training sequences. For this
purpose, 3GPP TS 45.002 defines two sets of training sequence codes (TSC). One
VAMOS user/subchannel gets a training sequence from TSC set 1, the other from TSC
set 2. This ensures that the two training sequences have a low cross-correlation. All
mobiles must support TSC set 1, but only mobiles explicitly indicating support for
VAMOS must also support TSC set 2.

In the uplink, two GMSK modulated signals interfere with each other and the base sta-
tion receiver requires an advanced multi-user detection algorithm.

In the downlink, a novel modulation scheme is used for each subchannel. The two sub-
channels are combined orthogonally by mapping them to the I and Q axis. This results

VAMOS (Voice services over Adaptive Multi-User channels on One Slot)
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in a QPSK modulation scheme, where each constellation point has a subchannel 1
component and a subchannel 2 component, as shown in the following figure.

Figure 3-1: QPSK modulation, sum of both subchannels

In this figure, both subchannels use the same power level. VAMOS allows subchannel-
specific power control, so that the two subchannels can use different power levels, e.g.
when the two users are located at different distances from the base station. The result-
ing modulation scheme is called adaptive QPSK (AQPSK). The following figure shows
an example where subchannel 2 mapped to the Q-axis uses a higher power level than
subchannel 1 mapped to the I-axis.

Figure 3-2: AQPSK modulation, subchannel 2 with higher power level

VAMOS (Voice services over Adaptive Multi-User channels on One Slot)
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The power level of subchannel 2 relative to the power level of subchannel 1 is called
subchannel power imbalance ratio (SCPIR). It is related to the angle α as follows:

SCPIR = 20 * log10(tan α) dB

Where the value of α is chosen such that |SCPIR|≤10dB

For α = 45° the SCPIR equals 0 dB and the two power levels are equal.

AQPSK modulation is applied in the downlink if speech frames have to be transmitted
on both subchannels simultaneously.

In this implementation, you can set the SCPIR and configure the VAMOS subchannels,
TSC set and TSC used. The available VAMOS settings depend on the mode the signal
is generated in:
● "Unframed"

Two data sources are provided, one per each VAMOS subchannel; the data is
AQPSK modulated but only one SCPIR can be configured.

● "Framed (Single)"
Full rate, half rate and combination of both slot types are supported. The character-
istics of each of the half rate slots can be adjusted individually
Separate data source is provided per each VAMOS subchannel and each user in
half rate mode; the data is AQPSK modulated and eight SCPIRs can be configured
Training sequence (TSC) set and TSC used can be configured on a VAMOS sub-
channel/User basis

● "Framed (Double)"
The settings of each of the two frames are as in the "Framed (Single)" mode.

VAMOS (Voice services over Adaptive Multi-User channels on One Slot)
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4  GSM/EDGE Configuration and Settings
Access:

► Select "Baseband > GSM/EDGE".

The remote commands required to define these settings are described in Chapter 5,
"Remote-Control Commands", on page 61.

4.1  General Settings

This tab provides access to the default and the "Save/Recall" settings. The selected
sequence mode determines the available parameters.

State..............................................................................................................................13
Set to Default................................................................................................................ 14
Save/Recall................................................................................................................... 15
Generate Waveform File…............................................................................................15
Sequence Mode............................................................................................................ 15
Symbol Rate Mode........................................................................................................15
Simulation Mode .......................................................................................................... 15
Modulation/Filter............................................................................................................16
Power Ramping/Slot Attenuations................................................................................ 16

State
Activates the standard and deactivates all the other digital standards and digital modu-
lation modes in the same path.

Remote command: 
[:SOURce<hw>]:BB:GSM:STATe on page 68

General Settings
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Set to Default
Calls the default settings. The values of the main parameters are listed in the following
table.

Parameter Value

State Not affected by "Set to Default"

Mode Framed (single)

Modulation  

Symbol Rate Mode Normal Symbol Rate

Symbol Rate 270.833 ksymb/s

Ignore 1/4... Off

Force Dummy Bits to 1 Off

Mod. Type GSM MSK 1bit/sym

Filter Gauss

Filter Par. BT 0.3

Power Ramp Control  

Ramp Time 2 sym

Function Cosine

Slot Attenuation 1...7 0 dB

Slot 0 Configuration  

Burst Type Normal (full rate)

Slot Level Full

Multislot Off

Number of Slots 1

Data PRBS 9

Use Stealing Flag On

Stealing Flag 0

TSC Set 1, TSC 0

Slot 1 to 7 Configuration  

Slot Level,

other settings as slot 0

Off

Remote command: 
[:SOURce<hw>]:BB:GSM:PRESet on page 65

General Settings
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Save/Recall
Accesses the "Save/Recall" dialog, that is the standard instrument function for saving
and recalling the complete dialog-related settings in a file. The provided navigation
possibilities in the dialog are self-explanatory.

The filename and the directory, in which the settings are stored, are user-definable; the
file extension is however predefined.

See also, chapter "File and Data Management" in the R&S SMW user manual.

Remote command: 
[:SOURce<hw>]:BB:GSM:SETTing:CATalog? on page 65
[:SOURce<hw>]:BB:GSM:SETTing:LOAD on page 66
[:SOURce<hw>]:BB:GSM:SETTing:STORe on page 66
[:SOURce<hw>]:BB:GSM:SETTing:DELete on page 66

Generate Waveform File…
With enabled signal generation, triggers the instrument to store the current settings as
an ARB signal in a waveform file. Waveform files can be further processed by the ARB
and/or as a multi-carrier or a multi-segment signal.

The filename and the directory it is stored in are user-definable; the predefined file
extension for waveform files is *.wv.

Remote command: 
[:SOURce<hw>]:BB:GSM:WAVeform:CREate on page 68

Sequence Mode
Selects GSM/EDGE mode.

There are three modes available:
● Unframed

See Chapter 4.6, "Mode Unframed", on page 24
● Framed (single)

See Chapter 4.7, "Mode Framed (Single)", on page 25
● Framed (double)

See Chapter 4.8, "Mode Framed (Double)", on page 28

Remote command: 
[:SOURce<hw>]:BB:GSM:MODE on page 64

Symbol Rate Mode
(with option R&S SMW-K41 EDGE Evolution)

Set the symbol rate mode, i.e. determines whether a normal burst (NB) or higher sym-
bol rate bursts (HB) is generated.

Remote command: 
[:SOURce<hw>]:BB:GSM:SRATe:MODE on page 68

Simulation Mode
Selects the modulation for the signal for the "Unframed" "Sequence Mode"

The signal is generated without slot or frame structure.

General Settings
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The available simulation modes depend on the selected symbol rate:
● Normal Symbol Rate - GSM (MSK or FSK), AQPSK, 8PSK/EDGE, 16QAM and

32QAM
● Higher Symbol Rate - HSR QPSK, HSR 16QAM and HSR 32QAM.
For GSM, the modulation to be used (MSK or FSK) is set by means of the parameter
"Modulation" in the "Modulation/Filter" menu.

Note: "Higher Symbol Rate Mode" and "Simulation Modes" AQPSK, 16QAM, 32QAM,
HSR QPSK, HSR 16QAM and HSR 32QAM require option R&S SMW-K41 EDGE Evo-
lution

Remote command: 
[:SOURce<hw>]:BB:GSM:SMODe on page 67

Modulation/Filter
Access the "Modulation/Filter" dialog, see Chapter 4.10, "Modulation/Filter",
on page 31.

Remote command: 
n.a.

Power Ramping/Slot Attenuations
For a framed "Sequence Mode", accesses the "Power Ramping/Slot Attenuation" dia-
log. This dialog is used to set the power ramping parameters and for setting values for
the level attenuation in dB, see Chapter 4.11, "Power Ramping/Slot Attenuation",
on page 40.

The currently selected ramp function and ramp time are displayed.

Remote command: 
n.a.

4.2  Trigger Settings

This tab provides access to the settings necessary to select and configure the trigger,
like trigger source, mode, trigger delay, trigger suppression, as well as to arm or trigger
an internal trigger manually. The current signal generation status is displayed in the
header of the tab together with information on the enabled trigger mode. As in the
"Marker" and "Clock" tabs, this tab provides also access to the settings of the related
connectors.

This section focuses on the available settings.
For information on how these settings affect the signal, refer to section "Basics on ..."
in the R&S SMW user manual.

Access:

► Select "Baseband > GSM/EDGE > Trigger In".

Trigger Settings
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This dialog comprises the settings required for configuring the trigger signal.

Routing and enabling a trigger
The provided trigger signals are not dedicated to a particular connector. Trigger signals
can be mapped to one or more USER x or T/M connectors.
Use the Local and Global Connector Settings to configure the signal mapping, the
polarity, the trigger threshold and the input impedance of the input connectors.
To route and enable a trigger signal, perform the following general steps:
● Define the signal source and the effect of a trigger event.

Select the "Trigger In > Mode" and "Trigger In > Source".
● Define the connector where the selected signal is provided.

Use the "Global Connectors" settings.

Trigger Settings Common to All Basebands
To enable simultaneous signal generation in all basebands, the R&S SMW couples the
trigger settings in the available basebands in any instrument's configuration involving
signal routing with signal addition. For example, in MIMO configuration, routing and
summing of basebands or of streams.

The icon  indicates that common trigger settings are applied.

You can access and configure the common trigger source and trigger mode settings in
any of the basebands. An arm or a restart trigger event applies to all basebands, too.
You can still apply different delay to each of the triggers individually.

Trigger Mode
Selects trigger mode, i.e. determines the effect of a trigger event on the signal genera-
tion.

For more information, refer to chapter "Basics" in the R&S SMW user manual.

● "Auto"
The signal is generated continuously.

● "Retrigger"
The signal is generated continuously. A trigger event (internal or external) causes a
restart.

● "Armed Auto"
The signal is generated only when a trigger event occurs. Then the signal is gener-
ated continuously.
An "Arm" stops the signal generation. A subsequent trigger event (internal or exter-
nal) causes a restart.

Trigger Settings
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● "Armed Retrigger"
The signal is generated only when a trigger event occurs. Then the signal is gener-
ated continuously. Every subsequent trigger event causes a restart.
An "Arm" stops signal generation. A subsequent trigger event (internal or external)
causes a restart.

● "Single"
The signal is generated only when a trigger event occurs. Then the signal is gener-
ated once to the length specified at "Signal Duration".
Every subsequent trigger event (internal or external) causes a restart.

Remote command: 
[:SOURce<hw>]:BB:GSM[:TRIGger]:SEQuence on page 82

Signal Duration Unit
Defines the unit for describing the length of the signal sequence to be output in the
"Single" trigger mode.

Remote command: 
[:SOURce<hw>]:BB:GSM:TRIGger:SLUNit on page 84

Trigger Signal Duration
Enters the length of the signal sequence to be output in the "Single" trigger mode.

Use this parameter to output part of the signal deliberately, an exact sequence of the
signal, or a defined number of repetitions of the signal.

Remote command: 
[:SOURce<hw>]:BB:GSM:TRIGger:SLENgth on page 84

Running/Stopped
With enabled modulation, displays the status of signal generation for all trigger modes.
● "Running"

The signal is generated; a trigger was (internally or externally) initiated in triggered
mode.

● "Stopped"
The signal is not generated and the instrument waits for a trigger event.

Remote command: 
[:SOURce<hw>]:BB:GSM:TRIGger:RMODe? on page 84

Arm
Stops the signal generation until subsequent trigger event occurs.

Remote command: 
[:SOURce<hw>]:BB:GSM:TRIGger:ARM:EXECute on page 83

Execute Trigger
For internal trigger source, executes trigger manually.

Remote command: 
[:SOURce<hw>]:BB:GSM:TRIGger:EXECute on page 83

Trigger Settings
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Trigger Source
The following sources of the trigger signal are available:
● "Internal"

The trigger event is executed manually by the "Execute Trigger".
● "Internal (Baseband A/B)"

The trigger event is provided by the trigger signal from the other basebands.
If common trigger settings are applied, this trigger source is disabled.

● "External Global Trigger"
The trigger event is the active edge of an external trigger signal provided and con-
figured at the USER x connectors.

● "External Local Trigger"
The trigger event is the active edge of an external trigger signal provided and con-
figured at the local T/M/C connector.
With coupled trigger settings, the signal has to be provided at the T/M/C1/2/3 con-
nectors.

● "External Local Clock"
The trigger event is the active edge of an external local clock signal provided and
configured at the local T/M/C connector.
With coupled trigger settings, the signal has to be provided at the T/M/C1 connec-
tor.

● "Baseband Sync In"
Option: R&S SMW-B9
In master-slave mode, slave instruments are triggered by the active edge of the
synchronization signal.

"External Local Clock/Trigger" require R&S SMW-B10.

Remote command: 
[:SOURce<hw>]:BB:GSM:TRIGger:SOURce on page 85

Sync. Output to External Trigger/Sync. Output to Trigger
Enables signal output synchronous to the trigger event.
● "On"

Corresponds to the default state of this parameter.
The signal calculation starts simultaneously with the trigger event. Because of the
processing time of the instrument, the first samples are cut off and no signal is out-
put. After elapsing of the internal processing time, the output signal is synchronous
to the trigger event.

● "Off"

Trigger Settings
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The signal output begins after elapsing of the processing time. Signal output starts
with sample 0. The complete signal is output.
This mode is recommended for triggering of short signal sequences. Short sequen-
ces are sequences with signal duration comparable with the processing time of the
instrument.

In master-slave mode, this setting ensures that once achieved, synchronization is not
lost if the baseband signal sampling rate changes.

Remote command: 
[:SOURce<hw>]:BB:GSM:TRIGger:EXTernal:SYNChronize:OUTPut
on page 83

External Trigger Inhibit
Applies for external trigger signal or trigger signal from the other path.

Sets the duration with that any following trigger event is suppressed. In "Retrigger"
mode, for example, a new trigger event does not cause a restart of the signal genera-
tion until the specified inhibit duration does not expire.

For more information, see chapter "Basics" in the R&S SMW user manual.

Remote command: 
[:SOURce<hw>]:BB:GSM:TRIGger[:EXTernal]:INHibit on page 85
[:SOURce<hw>]:BB:GSM:TRIGger:OBASeband:INHibit on page 84

Trigger Delay
Delays the trigger event of the signal from:
● The external trigger source
● The other path
● The other basebands (internal trigger), if common trigger settings are used.
Use this setting to:
● Synchronize the instrument with the device under test (DUT) or other external devi-

ces
● Postpone the signal generation start in the basebands compared to each other
● Compensate delays and align the signal generation start in multi-instrument setup
For more information, see chapter "Basics on ..." in the R&S SMW user manual.

Remote command: 
[:SOURce<hw>]:BB:GSM:TRIGger[:EXTernal]:DELay on page 85
[:SOURce<hw>]:BB:GSM:TRIGger:OBASeband:DELay on page 83

Trigger Settings
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4.3  Marker Settings

This tab provides access to the settings necessary to select and configure the marker
output signal, like the marker mode or marker delay settings.

This section focuses on the available settings.
For information on how these settings affect the signal, refer to section "Basics on ..."
in the R&S SMW user manual.

Access:

► Select "Baseband > GSM/EDGE > Marker".

This dialog comprises the settings required for configuring the marker.

Routing and enabling a marker
The provided marker signals are not dedicated to a particular connector. They can be
mapped to one or more USER x or T/M connectors.
To route and enable a marker signal, perform the following general steps:
● Define the shape of the generated marker, i.e. select the "Marker > Mode".
● Define the connector where the selected signal is provided.

Use the Local and Global Connector Settings.

Marker Mode
Marker configuration for up to 3 markers. The settings are used to select the marker
mode defining the shape and periodicity of the markers. The contents of the dialog
change with the selected marker mode; the settings are self-explanatory.

"As defined in
Slots"

The marker defined for each slot separately in the burst editor is
used. The name of the marker is displayed to the right of the selec-
tion. Definition of the slot marker is described in Chapter 4.13, "Slot
Marker Definition", on page 56.

Marker Settings
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"Slot" A slot clock with the slot period specified under Period is generated
on the output connector. The marker signal is generated after every
specified number of slots.
It is important to be aware of the variation in the GSM/EDGE slot
length 156 to 157 symbols. At a slot length of 156 symbols, a period
of 1 symbol and a symbol rate of 270.833 ksymb/s the clock is
0.577 ms. At 157 symbols, it is 0.580 ms

"Restart" A marker signal is generated at the start of each ARB sequence.

"Frame " A frame clock with the frame period specified under "Period" is gener-
ated on the output connector. The marker signal is generated after
every specified number of frames.
A GSM/EDGE frame has 1250 symbols. At a symbol rate of 270.833
ksymb/s and a period of 1, the clock is 4.615 ms.

"Pulse" A regular marker signal is generated. The pulse frequency is defined
by entering a divider. The frequency is derived by dividing the sample
rate by the divider. The input box for the divider opens when "Pulse"
is selected, and the resulting pulse frequency is displayed below it.
The maximum pulse frequency is half the symbol rate.

Remote command: 
[:SOURce<hw>]:BB:GSM:TRIGger:OUTPut<ch>:PULSe:DIVider on page 88
[:SOURce<hw>]:BB:GSM:TRIGger:OUTPut<ch>:PULSe[:FREQuency]?
on page 88

"Pattern" A marker signal that is defined by a bit pattern is generated. The pat-
tern has a maximum length of 64 bits and is defined in an input field
which opens when pattern is selected.

Remote command: 
[:SOURce<hw>]:BB:GSM:TRIGger:OUTPut<ch>:PATTern on page 87

"ON/OFF
Period"

A regular marker signal that is defined by an ON/OFF ratio is gener-
ated. A period lasts one ON and OFF cycle.

Remote command: 
[:SOURce<hw>]:BB:GSM:TRIGger:OUTPut<ch>:ONTime on page 87
[:SOURce<hw>]:BB:GSM:TRIGger:OUTPut<ch>:OFFTime on page 87

Remote command: 
[:SOURce<hw>]:BB:GSM:TRIGger:OUTPut<ch>:MODE on page 86

Marker x Delay
Delays the marker signal at the marker output relative to the signal generation start.

Variation of the parameter "Marker x Delay" causes signal recalculation.

Remote command: 
[:SOURce<hw>]:BB:GSM:TRIGger:OUTPut<ch>:DELay on page 89

Marker Settings
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4.4  Clock Settings

This tab provides access to the settings necessary to select and configure the clock
signal, like the clock source and clock mode.

This section focuses on the available settings.
For information on how these settings affect the signal, refer to section "Basics on ..."
in the R&S SMW user manual.

Access:

► Select "Baseband > GSM/EDGE > Clock".

This dialog comprises the settings required for configuring the clock.

Defining the clock
The provided clock signals are not dedicated to a particular connector. They can be
mapped to one or more USER x and T/M/C connectors.
Use the Local and Global Connector Settings to configure the signal mapping, the
polarity, the trigger threshold, and the input impedance of the input connectors.
To route and enable a trigger signal, perform the following general steps:
● Define the signal source, that is select the "Clock > Source".
● Define the connector where the selected signal is provided.

Use the Local and Global Connector Settings.

Clock Source
Selects the clock source.
● "Internal"

The instrument uses its internal clock reference.
● "External Local Clock"

Option: R&S SMW-B10
The instrument expects an external clock reference at the local T/M/C connector.

"External Local Clock" requires R&S SMW-B10.

Remote command: 
[:SOURce<hw>]:BB:GSM:CLOCk:SOURce on page 81

Clock Mode
Option: R&S SMW-B10

Sets the type of externally supplied clock.

Clock Settings
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Remote command: 
[:SOURce<hw>]:BB:GSM:CLOCk:MODE on page 81

Measured External Clock
Provided for permanent monitoring of the enabled and externally supplied clock signal.

Remote command: 
CLOCk:INPut:FREQuency?

4.5  Local and Global Connector Settings

Each of the "Trigger In", "Marker" and "Clock" dialogs and the "Trigger Marker Clock"
dialog provides a quick access to the related connector settings.

See also chapter "Local and Global Connector Settings" in the user manual.

4.6  Mode Unframed

1. To access this dialog select "General > Sequence Mode > Unframed".

2. Select "Unframed Configuration".

This dialog displays the signal in "Unframed" mode - no frames, no power ramping.

In "Unframed" mode, a modulation signal without slot or frame structure is generated.
The modulated carrier without power ramping is often enough for initial tests, and in
case the complete signal is not yet needed.

Mode Unframed
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Since all the modulation parameters for the signal are conform to the standard, only
the symbol rate mode and the modulation have to be selected. The symbol rate and
filter configuration are set accordingly.

This mode can be used for quick measurements of the spectrum or signal quality (e.g.
EVM).

Data
Selects data source.

The following standard data sources are available:
● "All 0, All 1"

An internally generated sequence containing 0 data or 1 data.
● "PNxx"

An internally generated pseudo-random noise sequence.
● "Pattern"

An internally generated sequence according to a bit pattern.
Use the "Pattern" box to define the bit pattern.

● "Data List/Select DList"
A binary data from a data list, internally or externally generated.
Select "Select DList" to access the standard "Select List" dialog.
– Select the "Select Data List > navigate to the list file *.dm_iqd > Select" to

select an existing data list.
– Use the "New" and "Edit" functions to create internally new data list or to edit

an existing one.
– Use the standard "File Manager" function to transfer external data lists to the

instrument.
See also:
● Section "Modulation Data" in the R&S SMW user manual.
● Section "File and Data Management" in the R&S SMW user manual.
● Section "Data List Editor" in the R&S SMW user manual

Remote command: 
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>][:SOURce]:DATA on page 95
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>][:SOURce]:DATA:PATTern on page 97
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>][:SOURce]:DATA:DLISt on page 96

4.7  Mode Framed (Single)

1. To access this dialog select "General > Sequence Mode > Framed (Single)".

2. Select "Framed (Single) Configuration".

Mode Framed (Single)
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This dialog displays the frame structure and provides access to the dialog for sav-
ing and loading a frame structure.

The "Framed (single)" mode generates a modulation signal which is defined by the
structure of a single frame. The frame structure is repeated cyclically, but the useful
data is continuously generated.

The frame structure is displayed in graphical form. Slot parameters can be defined in
the burst editor, which is called when the slot is selected in the graphical display (see
Chapter 4.12, "Burst Editor", on page 44). You can define half rate slots. The charac-
teristics of each half rate slot can be defined separately. Each active slot is represented
by a burst symbol. Two half rate slots occupy the space of a full rate slot. A slot in
which the level has been attenuated is represented by a lower amplitude burst. Inactive
slots (Slot Level = Off) are shown as a horizontal bar. Defined multislots are banded
and surrounded by a frame.

When a half rate slot has been selected, two frames are generated alternately. Each
frame holds one of the two half rate users.

Mode Framed (Single)
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Example: 
The following configuration is set, from a frame with two slots that contain half rate
users:

As a result, the following two frames are generated alternately:
● Frame with half rate user 1:

● Frame with half rate user 2

Save/Recall Frame …
Access the "Save/Recall Frame" dialog for selecting of predefined or user defined
frames, see Chapter 4.9, "Save Recall Frame/Slots", on page 29.

Remote command: 
n.a.

Mode Framed (Single)
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4.8  Mode Framed (Double)

1. To access this dialog select "General > Sequence Mode > Framed (Double)".

2. Select "Framed (Double) Configuration".

This dialog displays the frame structure and gives access to the dialog for saving
and loading a frame structure.

The "Framed (double)" mode generates multiframe signals which are defined by the
structure of two frames.

For this purpose, two frames are defined as in "Framed (single)" mode. A repetition
factor is then specified for each of the two frames. Following a trigger the first frame is
repeated the specified number of times, and then the second frame. The frame struc-
tures are repeated cyclically, but the useful data is continuously generated.

If one of the frames contains half rate slots (and so actually consists of two frames
itself), the repetition factor must be a multiple of 2 (seeChapter 4.7, "Mode Framed
(Single)", on page 25 ).

The frame structure of the two frames is displayed in graphical form. Slot parameters
can be defined in the burst editor, which is called when the slot is selected in the
graphical display (seeChapter 4.12, "Burst Editor", on page 44 ).

Save/Recall Frame …
Provides access to the "Save/Recall Frame" dialog for selecting of predefined or user
defined frames, see Chapter 4.9, "Save Recall Frame/Slots", on page 29 .

Remote command: 
n.a.

Frame Repetition
Sets the number of repetitions for frame 1 or frame 2. First frame 1 is repeated the
specified number of times, and then frame 2, then frame 1 starts again, and so on.

Mode Framed (Double)
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Remote command: 
[:SOURce<hw>]:BB:GSM:FRAMe<di>:REPetitions on page 63

4.9  Save Recall Frame/Slots

1. To access these dialogs select "General > Sequence Mode > Framed (Single) /
Framed (Double)".

2. Select "Framed (Single) / Framed (Double) Configuration" .

3. To access the "Save/Recall Frame" dialog, select "Save/Recall Frame"

4. To access the "Save/Recall Slots " dialog, select "Frame x: Select Slot to configure
> Slot... > Save/Recall Slots"

The "File Select" dialogs save and load (i.e. recall) user-defined frames or slots. Prede-
fined frames or slots can also be recalled. Each dialog offer access to the "File Man-
ager" for general file management.

Predefined Frames and Slots are stored on a predefined path. This path is automati-
cally set in the "File Select" dialog.

In the Normal Symbol Rate mode, user-defined Frames and Slots are stored as files
with the specific file extensions *.gsm_fu or *.gsm_slu, respectively.

In the Higher Symbol Rate mode, user-defined Frames and Slots are stored as files
with the specific file extensions *.gsm_hfu or *.gsm_hslu, respectively. Independ-
ent of the selected symbol rate mode, the files with user-defined Frames and Slots can
be stored in a user-determined directory and called from there.

It is not possible to use other file extensions. Attempting to do so causes an error mes-
sage. If the file extension is modified (e.g. by directly accessing the file system), the
files are no longer recognized and therefore invalid.

In the following examples of commands, the files are stored in the default directory
which is defined by command MMEM:CDIRectory.

Recall Predefined Files
Accesses the standard "File Select" dialog for loading a predefined frame/slot.

"EDGE0" Predefined frame
Slot 0 = On, full level, EDGE burst, all other slots off.

"EDGEAll" Predefined frame
All slots On, full level, EDGE burst

"GsmEdge" Predefined frame
Alternately one slot with NORMAL burst and EDGE burst

Save Recall Frame/Slots
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"NormalBurst0"
Predefined frame
Slot 0 = On, full level, NORMAL burst (full rate), all other slots off

"NormalBurstAll"
Predefined frame
All slots On, full level, NORMAL burst (full rate)

"GSM_NB_PN9_TSC0"
Predefined slot
NORMAL burst (full rate), full level, attenuation A1, multislot = Off,
number of multislots = 1, Data = PRBS 9, Use Stealing Flag = On,
TSC0, all slot-marker set to "all down".

"GSM_NB_PN9_TSC0"
Predefined slot
EDGE burst (full rate), full level, attenuation A1, multislot = Off, num-
ber of multislots = 1, Data = PRBS 9, Use Stealing Flag = On, TSC0,
all slot-marker set to "all down"

Remote command: 
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:PREDefined:CATalog? on page 70
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:PREDefined:LOAD on page 71
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>]:PREDefined:CATalog? on page 71
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>]:PREDefined:LOAD on page 72

Recall User Files
Access the standard "File Select" dialog for loading a user-defined frame/slot.

Remote command: 
[:SOURce<hw>]:BB:GSM:FRAMe<di>:ULISt:CATalog? on page 69
[:SOURce<hw>]:BB:GSM:FRAMe<di>:ULISt:LOAD on page 70
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>]:ULISt:CATalog? on page 72
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>]:ULISt:LOAD on page 73

Save User Files
Access the standard "File Select" dialog for saving the current frame or slot settings.

Remote command: 
[:SOURce<hw>]:BB:GSM:FRAMe<di>:ULISt:STORe on page 70
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>]:ULISt:STORe on page 73

File Manager
Access the standard "File Manager" dialog, used to copy, delete and rename files and
to create directories.

Save Recall Frame/Slots
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Remote command: 
[:SOURce<hw>]:BB:GSM:FRAMe<di>:ULISt:DELete on page 69
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>]:ULISt:DELete on page 72

4.10  Modulation/Filter

This dialog provides access to the modulation and filter settings. The selected symbol
rate mode and symbol rate determine the available modulation types.

Access:

1. Select "Baseband > GSM/EDGE > General".

2. Select "Modulation/Filter...."

This dialog contains the settings required for configuring the modulation types, the
corresponding filter settings and the ARB settings.

"Higher Symbol Rate Mode", AQPSK modulation and higher order modulations
(16QAM and 32QAM) are with option R&S SMW-K41 (EDGE evolution).

4.10.1  General Settings

Access:

► Select "General".

This tab contains the parameters to configure the general modulation settings.

Modulation/Filter
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Settings:

Symbol Rate .................................................................................................................32
Ignore 1/4 symbol (slot length 156 sym) / Ignore ½ symbol (slot length 187 sym) ...... 32
Force Dummy Bits to 1 .................................................................................................32

Symbol Rate
Sets the symbol rate.

The symbol rate is determined by the selected "Symbol Rate Mode":
● "Normal Symbol Rate"

Sets 270.833 33 ksymb/s default symbol rate for GSM/EDGE.
● "Higher Symbol Rate"

Sets 325 ksymb/s default symbol rate for EDGE evolution.

Remote command: 
[:SOURce<hw>]:BB:GSM:SRATe on page 67

Ignore 1/4 symbol (slot length 156 sym) / Ignore ½ symbol (slot length 187 sym)
Selects constant slot length. This setting affects all burst types.

In a normal burst (NB), the GSM slot has a length of 156.25 symbols. Compensation
for the 1/4 symbol takes the form of an extra symbol every 4th slot. This means that
some slots are 156 long and some are 157 long. Compensation takes place in the
guard field of the burst (seeChapter 4.12, "Burst Editor", on page 44 ).

In a higher symbol rate burst (HB), the average slot is 187.5 symbols long. Compensa-
tion for ½ symbol means that each second slot gets an extra symbol and is 188 sym-
bols long, while the rest uses a slot length of 187 symbols.

If the field "Ignore 1/4 symbol (slot length 156 symbols) / Ignore ½ symbol (slot length
187 symbols)" is enabled, all slots are 156 respectively 187 symbols long. The extra
1/4 resp. ½ symbol is omitted. The guard field for the burst always has the same length
regardless of the slot index.

For normal burst, a frame is therefore 1248 symbols long instead of 1250.

Respectively, the length of the frame in a higher symbol rate burst is than 1496 sym-
bols long instead of 1500 symbols.

Remote command: 
[:SOURce<hw>]:BB:GSM:ISLength on page 64

Force Dummy Bits to 1
A modulating bitstream consisting of consecutive ones is used for inactive slots
(according to GSM 05.04). If this parameter is disabled, the inactive slots are filled in
with 0.

Remote command: 
[:SOURce<hw>]:BB:GSM:FONE on page 63

Modulation/Filter
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4.10.2  MSK/FSK Settings

Access:

1. Select "Symbol Rate Mode > Normal Symbol Rate".

2. Select "MSK/FSK".

This tab contains the parameters required to configure the MSK/FSK modulation.

Modulation ....................................................................................................................33
FSK Deviation .............................................................................................................. 33
Filter ............................................................................................................................. 33
Filter Parameter ........................................................................................................... 34

Modulation
Selects the modulation type for the GSM signal.
● "MSK 1bit/symbol" = Minimum Shift Keying
● "FSK 1bit/symbol" = Frequency Shift Keying
The selected modulation is also displayed in graphical form.

Remote command: 
[:SOURce<hw>]:BB:GSM:FORMat on page 74

FSK Deviation
Sets the deviation for FSK.

When MSK is selected, the deviation is set permanently to symbol_rate/4.

Remote command: 
[:SOURce<hw>]:BB:GSM:FSK:DEViation on page 74

Filter
Indicates the filter used for the GSM signal. The filter is permanently set to Gauss.

Modulation/Filter
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Remote command: 
[:SOURce<hw>]:BB:GSM:FILTer:TYPE? on page 78

Filter Parameter
Sets the BxT value for the GAUSS filter. The GSM default value is 0.3.

Remote command: 
[:SOURce<hw>]:BB:GSM:FILTer:PARameter on page 78

4.10.3  AQPSK Settings

1. To access this dialog select "Symbol Rate Mode > Normal Symbol Rate".

2. Select "AQPSK".

This tab contains the parameters necessary to configure the AQPSK modulation
(requires option R&S SMW-K41.

Modulation AQPSK
Displays the modulation type for the GSM signal. The modulation type is set perma-
nently to AQPSK (see Chapter 3.3, "VAMOS (Voice services over Adaptive Multi-User
channels on One Slot)", on page 10).

Remote command: 
[:SOURce<hw>]:BB:GSM:AQPSk:FORMat? on page 75

Angle alpha_0 ... alpha_7
Sets the angle alpha (see Chapter 3.3, "VAMOS (Voice services over Adaptive Multi-
User channels on One Slot)", on page 10).

Remote command: 
[:SOURce<hw>]:BB:GSM:AQPSk:ANGLe<ch0> on page 77

Modulation/Filter
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SCPIR_0 to SCPIR_7
The power level of subchannel 1 relative to the power level of subchannel 2 is called
subchannel power imbalance ratio (SCPIR). It is related to the angle α as follows:

SCPIR = 20 * log10(tan α) dB,

Where the value of α is chosen such that |SCPIR|≤10dB

For α = 45° the SCPIR equals 0 dB and the two power levels are equal.

Remote command: 
[:SOURce<hw>]:BB:GSM:AQPSk:SCPIR<ch0> on page 77

Filter
Indicates the filter type used for AQPSK modulation. The filter is permanently set to
Gauss linearized.

Remote command: 
[:SOURce<hw>]:BB:GSM:FILTer:AQPSK:TYPE? on page 79

4.10.4  8 PSK/EDGE Settings

1. To access this dialog select "Symbol Rate Mode > Normal Symbol Rate".

2. Select "8 PSK/EDGE".

This tab contains the parameters required to configure the 8 PSK/EDGE modula-
tion.

Modulation Type EDGE
Displays the modulation type for the EDGE signal. The modulation type is set perma-
nently to 8PSK EDGE (3pi/8 8PSK). Unlike the modulation types for GSM, the modula-
tion type for EDGE has 3 bits per symbol.

Remote command: 
[:SOURce<hw>]:BB:GSM:EDGE:FORMat? on page 74

Modulation/Filter
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Filter
Indicates the filter used for the EDGE signal. The filter is permanently set to Gauss lin-
earized.

Remote command: 
[:SOURce<hw>]:BB:GSM:FILTer:EDGE:TYPE? on page 79

4.10.5  16QAM Settings

1. To access this dialog select "Symbol Rate Mode > Normal Symbol Rate".

2. Select "16 QAM".

This tab contains the parameters required to configure the 16 QAM modulation.
(requires option R&S SMW-K41)

Modulation Type 16QAM
Displays the modulation type for the signal.

The modulation type 16QAM has 4 bits per symbol.

Remote command: 
[:SOURce<hw>]:BB:GSM:N16Qam:FORMat? on page 76

Filter
Indicates the filter used for the 16QAM signal. The filter is permanently set to Gauss
linearized.

Remote command: 
[:SOURce<hw>]:BB:GSM:FILTer:N16Qam:TYPE? on page 79

Modulation/Filter
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4.10.6  32QAM Settings

1. To access this dialog select "Symbol Rate Mode > Normal Symbol Rate".

2. Select "32 QAM".

This tab contains the parameters required to configure the 32QAM modulation.
(requires option R&S SMW-K41)

Modulation Type 32QAM
Displays the modulation type for the signal.

The modulation type 32QAM has 5 bits per symbol.

Remote command: 
[:SOURce<hw>]:BB:GSM:N32Qam:FORMat? on page 77

Filter
Indicates the filter used for the 32QAM signal. The filter is permanently set to Gauss
linearized.

Remote command: 
[:SOURce<hw>]:BB:GSM:FILTer:N32Qam:TYPE? on page 79

4.10.7  HSR QPSK Settings

1. To access this dialog select "Symbol Rate Mode > Higher Symbol Rate".

2. Select "HSR QPSK".

Modulation/Filter
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This tab contains the parameters required to configure the HSR QPSK modulation.
(requires option R&S SMW-K41)

Modulation Type HSR QPSK
(for "Higher Symbol Rate")

Displays the modulation type for the signal.

The modulation type QPSK EDGE has 2 bits per symbol.

Remote command: 
[:SOURce<hw>]:BB:GSM:HQPSk:FORMat? on page 76

Filter
(for "Higher Symbol Rate")

Indicates the filters used for the HSR QPSK EDGE signal.

The two possible filters are displayed. The currently used filter is set per HSR QPSK
slot with the parameter "Filter".

Remote command: 
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>]:FILTer:TYPE on page 94
[:SOURce<hw>]:BB:GSM:FILTer:HQPSk:TYPE on page 80

4.10.8  HSR 16QAM Settings

1. To access this dialog select "Symbol Rate Mode > Higher Symbol Rate".

2. Select "HSR 16QAM".

This tab contains the parameters required to configure the HSR 16QAM modula-
tion.

Modulation/Filter
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Modulation Type HSR 16QAM
(for "Higher Symbol Rate")

Displays the modulation type for the signal.

The modulation type 16QAM has 4 bits per symbol.

Remote command: 
[:SOURce<hw>]:BB:GSM:H16Qam:FORMat? on page 75

Filter
(for "Higher Symbol Rate")

Indicates the filters used for the HSR 16QAM signal.

The two possible filters are displayed. The currently used filter is set per HSR 16QAM
slot with the parameter Filter.

Remote command: 
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>]:FILTer:TYPE on page 94
[:SOURce<hw>]:BB:GSM:FILTer:H32Qam:TYPE on page 80

4.10.9  HSR 32QAM Settings

1. To access this dialog select "Symbol Rate Mode > Higher Symbol Rate".

2. Select "HSR 32QAM".

This tab contains the parameters required to configure the HSR 32QAM modula-
tion.

Modulation Type HSR 32QAM
(for "Higher Symbol Rate")

Displays the modulation type for the signal.

The modulation type 32QAM has 5 bits per symbol.

Remote command: 
[:SOURce<hw>]:BB:GSM:H32Qam:FORMat? on page 75

Filter
(for "Higher Symbol Rate")

Indicates the filters used for the 32QAM signal.

Modulation/Filter
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The two possible filters are displayed. The currently used filter is set per HSR 32QAM
slot with the parameter Filter.

Remote command: 
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>]:FILTer:TYPE on page 94
[:SOURce<hw>]:BB:GSM:FILTer:H32Qam:TYPE on page 80

4.10.10  ARB Settings

Access:

1. Select "Baseband > GSM/EDGE > General".

2. Select "Modulation/Filter.... > ARB"

This tab contains the parameters required to configure the ARB waveform compo-
nent of the signal.

Sequence Length ARB
Sets the sequence length of the arbitrary waveform component of the signal. This com-
ponent is calculated in advance and output in the arbitrary waveform generator. It is
added to the realtime signal components.

The maximum number of frames depends on the installed ARB waveform memory size
and the current "Symbol Rate".

Remote command: 
[:SOURce<hw>]:BB:GSM:FLENgth on page 62

4.11  Power Ramping/Slot Attenuation

This dialog provides access to the settings for power ramping and level attenuation.

You can set the power ramp envelope, and define seven possible values for level
attenuation. Slot Attenuations, used in burst editors enables you to define seven possi-
ble values for level attenuation. These values can be selected from the burst editor for
the slot currently being edited. An eighth value is permanently set to 0 dB and corre-
sponds to the "Slot Level Full" setting in the burst editor.

Power Ramping/Slot Attenuation
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Power ramping /Level attenuation is used for restricting power ramping to the base-
band signal.

Access:

1. Select "Baseband > GSM/EDGE".

2. Select "Power Ramp/Slot Attenuation"

This dialog contains the parameters required to configure the power ramp enve-
lope and the slot attenuations.

3. Select "Slot Attenuations".

Power Ramping/Slot Attenuation
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You can define the seven values for level attenuation.

4. Select "Power Ramping/ Level Attenuation"

Enable the provided parameter to restrict power ramping to the baseband signal.

Power Ramp
Access:

Select "Baseband > GSM/EDGE > Power Ramp Slot Attenuations > Power Ramp".

Power Ramping/Slot Attenuation
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Ramp Function ← Power Ramp
Sets the form of the transmitted power during the switching operation, i.e. the shape of
the rising and falling edges of the envelope.

"Linear" The transmitted power rises and falls linear fashion.

"Cosine" The transmitted power rises and falls with a cosine-shaped edge.
This causes a more favorable spectrum than the "Linear" setting.

Remote command: 
[:SOURce<hw>]:BB:GSM:PRAMp:SHAPe on page 90

Ramp Time ← Power Ramp
Sets the power ramping rise time and fall time for a burst. The setting is expressed in
symbols.

Do not switch the transmitted power abruptly at the start and end of a burst, because
the switching operation would otherwise generate excessively strong non-harmonics.
The switching operation is therefore stretched over several symbol clocks.

Remote command: 
[:SOURce<hw>]:BB:GSM:PRAMp:TIME on page 91

Rise Delay ← Power Ramp
Sets the offset in the rising edge of the envelope at the start of a burst. A positive value
causes a delay and a negative value causes an advance. The setting is expressed in
symbols.

Remote command: 
[:SOURce<hw>]:BB:GSM:PRAMp:RDELay on page 90

Fall Delay ← Power Ramp
Sets the offset in the falling edge of the envelope at the end of a burst. A positive value
causes a delay and a negative value causes an advance. The setting is expressed in
symbols.

Remote command: 
[:SOURce<hw>]:BB:GSM:PRAMp:FDELay on page 89

Slot Attenuations
Access:

Select "Baseband > GSM/EDGE > Power Ramp Slot Attenuations > Slot Attenuations".

Slot Attenuation A1 to A7 ← Slot Attenuations
Sets the seven different values for level attenuation.

The burst editor can be used to set the level attenuation for the eight slots to one of
these predefined values independently of one another.

The burst editor is likewise used to assign the "Slot Level" attribute "Attenuated" to
individual slots.

Remote command: 
[:SOURce<hw>]:BB:GSM:SATTenuation<ch> on page 65
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In Bb Only
Access:

Select "Baseband > GSM/EDGE > Power Ramp Slot Attenuations > In Bb Only".

In Baseband Only ← In Bb Only
Restricts power ramping to the baseband signal.

"Off" Level attenuation is effected via the attenuator stages in the RF sec-
tion; only the remaining part is attenuated in the baseband. The sig-
nal is issued at the RF output with the defined level values. This set-
ting provides the best possible dynamic for burst signals.

"On" Level attenuation affects the baseband only.

This setting is mandatory in the following cases:
● When only the baseband signal is issued at the I/Q outputs

It is thus ensured that, with power ramping active, this signal is
output with the defined level values.

● When a baseband signal is applied to two RF paths of a two-path
instrument.
The RF paths having separate frequency and level settings, the
remaining attenuation in the baseband would have to be different
for the two paths and is therefore not possible.

● When a burst baseband signal (GSM/EDGE) is combined with a
continuous baseband signal (e.g. 3GPP), or a noise signal and
both signals are applied to one RF path.
Blanking in the RF is unsuitable, because the RF section would
not only blank the burst signal of the first baseband but also the
continuous signal or the noise signal.

Remote command: 
[:SOURce<hw>]:BB:GSM:PRAMp:BBONly[:STATe] on page 89

4.12  Burst Editor

This dialog provides the settings for configuring a burst slot. The burst type for the
selected slot, for example the burst structure determines the available parameters.

Access:

1. Select "Baseband > GSM/EDGE > General".

2. Select the "Sequence Mode"

3. Depending on the "Sequence Mode", select:

● "Unframed Configuration" or
● "Framed (Single) Configuration" or
● "Framed (Double) Configuration".

The corresponding dialog opens and displays a graph of the current frame.

4. In the frame graph "Frame: Select Slot To Configure", select a slot.

Burst Editor
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This dialog contains the parameters for configuring a burst slot. The graph shows
the structure of the current burst type.

The individual fields of the burst type are color-coded:

Field Color

Data, Fixed, Mixed, Stealing white

Training Sequences: TSC, ETSC, SYNC yellow

Tail, extended Tail green

Guard, extended Guard blue

"Higher Symbol Rate Mode", AQPSK modulation and higher order modulations
(16QAM and 32QAM) require optionR&S SMW-K41 (EDGE evolution).

Burst Type
Selects the burst type.

The burst types available depend on the selected "Symbol Rate Mode". The symbol
rate mode a burst type applies to is denoted ("Normal ..." and "HSR ..." ("high symbol
rate mode").

Note: "Higher Symbol Rate Mode", AQPSK modulation and higher order modulations
(16QAM and 32QAM) require optionR&S SMW-K41 (EDGE evolution).

"Normal (GMSK/Full Rate)"
The useful data is transmitted in the normal burst (NB).
A normal burst carries 2*58 = 116 encrypted bits.

Burst Editor
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"Normal (GMSK/Half Rate)"
The useful data is transmitted in the normal burst.
Half rate user 1 is transmitted in all the frames with an even index
(frames 0, 2, 4, etc.). Half rate user 2 is transmitted in the frames with
an odd index (frames 1, 3, etc.).
See alsoChapter 4.7, "Mode Framed (Single)", on page 25 .

"Normal (AQPSK/Full Rate - Full Rate)"
The data of pair of users is multiplexed on the two VAMOS subchan-
nels of a single physical radio resource.
See also Chapter 3.3, "VAMOS (Voice services over Adaptive Multi-
User channels on One Slot)", on page 10.

"Normal (AQPSK/Full Rate - Half Rate)"
Three users are using the same radio resource, one full rate VAMOS
user on the subchannel 1 and two half rate VAMOS users on the sub-
channel 2.

"Normal (AQPSK/Half Rate - Half Rate)"
A single timeslot is shared by four users: two VAMOS subchannels,
each used by two half rate users.

"Normal (8PSK/EDGE)"
The higher bit clock associated with EDGE achieves correspondingly
higher data transfer rates.
If a frame contains an active EDGE burst, the higher bit clock (3 x
symbol clock) is always output on the clock outputs. If the EDGE
burst is removed from the frame, the lower bit clock (=symbol clock)
is automatically output again.
An EDGE burst carries 2x(3*58) = 348 encrypted bits.

"Normal (16QAM)"
Selects a normal burst with 16QAM modulation scheme (4 bits per
symbol).
A normal 16QAM burst carries 2x(4*58) = 464 encrypted bits.
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"Normal
(32QAM)"

Selects a normal burst with 32QAM modulation scheme (5 bits per
symbol).
A normal 32QAM burst carries 2x(5*58) = 580 encrypted bits.

"Synchroniza-
tion"

(Normal Symbol Rate)
The synchronization burst is sent by the base station only and is used
for bit synchronization. For this purpose, it contains a 64-bit extended
training sequence.

"Frequency
Correction"

(Normal Symbol Rate)
The Frequency Correction burst is sent by the base station only. The
user equipment uses the burst to synchronize with the carrier fre-
quency and to compensate for any possible Doppler effect.

"Dummy" (Normal Symbol Rate)
The dummy burst is sent by the base station only. It acts as a modu-
lation signal when there is no data burst available. This burst type is
defined in the standard and has an unalterable, precisely defined
data pattern.

"Access" (Normal Symbol Rate)
This burst type is sent by a user equipment to a base station as the
first burst, to determine the timing advance. It is used for synchroniz-
ing with the base station.

"All Data
(GMSK)"

(Normal Symbol Rate)
This and the following normal symbol rate burst types are not defined
in the standard. They serve as the output basis for defining a new
burst type with user-programmable data content for test purposes.
An All_Data GMSK burst carries 148 encrypted bits.

"All Data
(AQPSK)"

An All_Data AQPSK burst carries 148 encrypted bits per subchannel.

"All Data
(8PSK/EDGE)"

(Normal Symbol Rate)
An All_Data EDGE burst carries 3x148 = 444 encrypted bits.
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"All Data
(16QAM)"

(Normal Symbol Rate)
An All_Data 16QAM burst carries 4x148 = 592 encrypted bits.

"All Data
(32QAM)"

(Normal Symbol Rate)
An All_Data 32QAM burst carries 5x148 = 740 encrypted bits.

"HSR (QPSK)" (Higher Symbol Rate)
Selects a higher symbol rate burst with QPSK modulation scheme (2
bits per symbol).
A higher symbol rate burst carries 2*69 = 138 unmodulated encrypted
bits, i.e. an HSR QPSK burst carries 2x(2*69) = 276 encrypted bits.

"HSR
(16QAM)"

(Higher Symbol Rate)
Selects a higher symbol rate burst with 16QAM modulation scheme
(4 bits per symbol).
An HSR 16QAM burst carries 4x(2*69) = 552 encrypted bits.

"HSR
(32QAM)"

(Higher Symbol Rate)
Selects a higher symbol rate burst with 32QAM modulation scheme
(5 bits per symbol).
An HSR 32QAM burst carries 5x(2*69) = 690 encrypted bits.

"HSR All Data
(QPSK)"

(Higher Symbol Rate)
This and the following higher symbol rate burst types are not defined
in the standard. They serve as the output basis for defining a new
burst type with user-programmable data content for test purposes.
An HSR All_Data QPSK burst carries 2x177 = 354 encrypted bits.

"HSR All Data
(16QAM)"

(Higher Symbol Rate)
An HSR All_Data 16QAM burst carries 4x177 = 708 encrypted bits.

"HSR All Data
(32QAM)"

(Higher Symbol Rate)
An HSR All_Data 32QAM burst carries 5x177 = 885 encrypted bits.
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Remote command: 
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>:TYPE on page 92

Save/Recall Slots
Accesses the "Save/Recall Slot" dialog with standard "File Select" and file manage-
ment functions, see Chapter 4.9, "Save Recall Frame/Slots", on page 29.

Remote command: 
n.a.

User x
When burst type "Normal (Half Rate)" is selected, the users can be set separately in
dialog sections User 1 and User 2.

Remote command: 
n.a.

SCPIR
Selects the SCPIR.

The value of SCPIR affects the shape of the AQPSK constellation, see Figure 3-2. For
an SCPIR of 0 dB, the constellation is square (as in "normal" QPSK), while for other
values of SCPIR the constellation becomes rectangular.

Use the Modulation/Filter dialog to define eight different values for SCPIR. You can
select from the values displayed.

Remote command: 
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>]:SCPIRatio on page 93

Slot Level
Sets the level for the selected slot.

"Off" Attenuation is maximum. The slot is inactive.

"Attenuated" Level is reduced by the level attenuation set in "Slot Attenuation".

"Full" The level corresponds to the level indicated in the display.

Remote command: 
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>]:LEVel on page 92

Slot Attenuation
Selects the level attenuation for the "Slot Level Attenuated" setting.

Use the Power Ramping/Slot Attenuation dialog to define seven different values for
level attenuation. You can select from the values displayed.

Remote command: 
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>]:ATTenuation on page 93

Filter
(Higher Symbol Rate slots require R&S SMW-K41)
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Selects whether a "Narrow Pulse Shape" or a "Wide Pulse Shape" filter is used for the
selected burst type and modulation.

Remote command: 
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>]:FILTer:TYPE on page 94

Multislot Configuration
Enables the previously set multislot mode.

Since multislot involves connecting multiple slots to a single user channel, this configu-
ration is possible for normal (full rate) bursts, normal (8PSK/EDGE) burst and EDGE
evolution bursts.

Several multislot groups can be defined within a frame. These groups are highlighted
when the frame structure is displayed in the main dialog (see Chapter 4.7, "Mode
Framed (Single)", on page 25).

The first slot in a multislot group is the master slot. This determines the parameters of
all the slots in the group. All the slots in a multislot group therefore have identical
parameters.

The multislot settings are valid for all the slots in the frames of a multiframe configura-
tion. If slots 1 and 2 are connected, for example, both these slots are connected in all
the frames of the multiframe signal.

Remote command: 
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:MULTislot<st0>:STATe on page 97

Number of Slots
Defines the number of consecutive slots that are linked to a multislot.

The multislot always starts with the current slot. The value range therefore depends on
the current slot index. A maximum of eight slots (slot 0 to slot 7) can be combined: 1 ...
(8 - current index).

Remote command: 
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:MULTislot<st0>:COUNt on page 94

VAMOS Offset Jitter
Option: R&S SMW-B14

Enables/disables the simulation of a timing jitter for GMSK bursts.
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The test specification 3GPP TS 45.005, annex Q5 defines that for uplink tests in
VAMOS mode, both interference and sensitivity limited cases are specified for VAMOS
subchannel 1. The VAMOS channel 1 is offset in time and frequency with respect to
VAMOS subchannel 2. If this parameter is activated, the instrument applies a timing
offset (jitter) with randomly selected value in the range of -1, 0 or 1 symbol period. The
timing offset changes between the bursts; within a burst, the instrument keeps the time
and frequency offsets constant.

Use the frequency offset parameters μ and σ to define the required Gaussian fre-
quency jitter.

Remote command: 
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>:VOJitter on page 94

Frequency offset parameters
Option: R&S SMW-B14

If VAMOS Offset Jitter is enabled, the frequency offset parameters μ and σ are applied.
The table below iluustrates typical values:
Table 4-1: Frequency offset parameters μ and σ

Frequency Band 850/900 1800 1900

μ 45 Hz 90 Hz 95 Hz

σ 10 Hz 17 Hz 17 Hz

mu  ← Frequency offset parameters
Defines the freuqency offset parameter μ required to define the random function for the
frequency offset. See also Table 4-1.

sigma ← Frequency offset parameters
Defines the freuqency offset parameter σ required to define the random function for the
frequency offset. See also Table 4-1.

Burst Fields
Comprises settings for configuring of the individual burst fields.
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The available settings depend on the selected Burst Type .

Extended Tail Bits ← Burst Fields
Displays the data content in the "ETail" data field of the access burst.

Extended tail bits fields are 8 bits long and permanently set at 0011 1010.

Remote command: 
n.a.

Tail Bits ← Burst Fields
Displays the data content in the "Tail" data field.

The content depends on the "Burst Type":
● Normal (GMSK...), normal (AQPSK...), synchronization, Frequency Correction,

dummy and access
"Tail Bit" field is 3 bits long and permanently set at 000.

● Normal(8PSK/EDGE)
"Tail Bit" field is 9 bits long and permanently set at 1 1111 1111.

● Normal (16QAM)
"Tail Bit" field is 12 bits long and permanently set at 0001 0110 0110.

● Normal (32QAM)
"Tail Bit" field is 15 bits long and permanently set at 111 1001 1100 1110.

Remote command: 
n.a.

Data for Data Field of Slot ← Burst Fields
Selects a data source for the DATA field.

If a burst contains multiple DATA fields, these are treated as a continuous field. For
example, a pseudo-random sequence is continued without interruption from one DATA
field to the next.

The following standard data sources are available:
● "All 0, All 1"

An internally generated sequence containing 0 data or 1 data.
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● "PNxx"
An internally generated pseudo-random noise sequence.

● "Pattern"
An internally generated sequence according to a bit pattern.
Use the "Pattern" box to define the bit pattern.

● "Data List/Select DList"
A binary data from a data list, internally or externally generated.
Select "Select DList" to access the standard "Select List" dialog.
– Select the "Select Data List > navigate to the list file *.dm_iqd > Select" to

select an existing data list.
– Use the "New" and "Edit" functions to create internally new data list or to edit

an existing one.
– Use the standard "File Manager" function to transfer external data lists to the

instrument.
See also:
● Section "Modulation Data" in the R&S SMW user manual.
● Section "File and Data Management" in the R&S SMW user manual.
● Section "Data List Editor" in the R&S SMW user manual

Remote command: 
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>][:SOURce]:DATA on page 95
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>][:SOURce]:DATA:PATTern on page 97
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>][:SOURce]:DATA:DLISt:CATalog? on page 96
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>][:SOURce]:DATA:DLISt on page 96

Use Stealing Flag ← Burst Fields
Sets the use stealing flag feature. The setting applies to both S fields. If not used, the
flag stealing bit is allocated to the data field concerned, which then becomes 58 data
bits long instead of 57.

Remote command: 
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>]:SFLag:USE on page 98

Stealing Flag ← Burst Fields
Sets a value for the stealing flag feature. The setting applies to both S fields.

Remote command: 
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>]:SFLag on page 98

TSC Set ← Burst Fields
Determine whether the GMSK normal burst or VAMOS subchannel uses training
sequence TSC set 1 or set 2.

Assign different TSC set to each of the two subchannels to ensure that the training
sequences configured for the VAMOS subchannels have a low cross-correlation.
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Remote command: 
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>][:SOURce]:TSC:SET on page 99

TSC ← Burst Fields
Selects the training sequence code.

There are 8 predefined training sequences to choose from in each case; those for
GSM are 26 bits long and those for EDGE are 78 bits.

A user-defined training sequence can be created in the User TSC field and is then also
available for selection.

Remote command: 
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>][:SOURce]:TSC:SELect on page 99

TSC Pattern ← Burst Fields
Edits selected training sequence.

When a sequence has been changed, the TSC field displays the indication "User".

When a frame/slot is saved, the amended training sequence is also saved.

User-defined training sequences can be used among other things to test the reaction
of receivers to interference-laden training sequences (e.g. 1-bit toggle).

Remote command: 
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>][:SOURce]:TSC:USER on page 99

Ext Training Seq ETSC ← Burst Fields
Selects the extended training sequence code (ETSC) for the synchronization burst.

There is a choice of three predefined, 64-bit extended training sequences. Also, a
user-defined extended training sequence can be defined in the User ETSC field and is
then also available for selection.

Remote command: 
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>]:ETSC on page 100

ETSC Pattern ← Burst Fields
Edits selected ETSC for the synchronization burst.

When a sequence has been changed, the "Ext Training Seq ETSC" field also displays
"User" as a possible choice.

When a frame/slot is saved, the changed extended training sequence is also saved.

Remote command: 
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>]:ETSC:USER on page 100

Training Sequence Sync ← Burst Fields
Selects training sequence sync for the "Access" burst.

Burst Editor
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There is a choice of three predefined, 41-bit training sequences sync. Also, user-
defined training sequence sync can be defined in the "User Sync" field and is then also
available for selection.

Remote command: 
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>]:SYNC:SELect on page 100

Sync Pattern ← Burst Fields
Edits the training sequence sync for the access burst.

When a sequence has been changed, the "Training Sequence Sync" field also displays
"User" as a possible choice.

When a frame/slot is saved, the amended training sequence sync is also saved.

Remote command: 
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>]:SYNC:USER on page 101

Fixed ← Burst Fields
Selects the data content of the fixed field in the Frequency Correction burst.

There is a choice of two fixed, 142-bit data contents prescribed by the standard, and a
user-defined one.

The user-defined pattern must be 142 bits long.

Remote command: 
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>]:FCORrection:FIXed on page 101

Fixed Pattern ← Burst Fields
Displays the data content of the fixed field in the Frequency Correction burst when
"Fixed Standard" or "Compact" is selected.

Enter the data content of the fixed field in the Frequency Correction burst when "Fixed
User" is selected. The pattern is 142 bits long.

Remote command: 
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>]:FCORrection:FIXed:PATTern on page 101

Mixed ← Burst Fields
Displays the data content of the mixed field in the dummy burst. It contains a fixed,
142-bit data content prescribed by the standard.

Remote command: 
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>]:DUMMy:MIXed:PATTern? on page 102

Guard ← Burst Fields
Displays the data content of the guard field in binary notation.

A frame contains exactly 1250 bits for normal burst and 1500 for higher symbol rate
burst. Hence, the length of the guard fields is different for different slots (see table).

Burst Editor
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 Normal Symbol Rate  

Slot # 0, 4 1 .. 3, 5 .. 7

Guard Length 9 symbol periods 8 symbol periods

 Higher Symbol Rate  

Slot # 0, 2, 4, 6 1, 3, 5, 7

Guard Length 11 symbol periods 10 symbol periods

If the field "Ignore 1/4 symbol (slot length 156 symbols) / Ignore 1/2 symbol (slot length
187 symbols)" is enabled, all slots are 156 respectively 187 symbols long. The extra
1/4 resp. 1/2 symbol is omitted. The guard field for the burst always has the same
length regardless of the slot index.

For normal burst, a frame is therefore 1248 symbols long instead of 1250.

Respectively, the length of the frame in a higher symbol rate burst is than 1496 sym-
bols long instead of 1500 symbols.

Remote command: 
n.a.

Extended Guard ← Burst Fields
Displays the data content of the extended guard field in the access burst.

In order for a frame to contain exactly 1250 symbols as prescribed in the GSM stan-
dard, the length of the extended Guard fields is different for different slots:

The field length is 68 bits in slots 1, 2, 3, 5, 6, 7; it is 69 bits in slots 0 and 4.

If the field "Ignore 1/4 symbol (slot length 156 symbols)" is enabled, all slots are 156
symbols long. The extra 1/4 symbol is omitted. The extended guard field for the burst
always has the same length regardless of the slot index. A frame is therefore 1248
symbols long in place of 1250.

Remote command: 
n.a.

Slot Marker Definition
Access the dialog for defining the marker signal at slot level. This dialog is described in
theChapter 4.13, "Slot Marker Definition", on page 56 .

Remote command: 
n.a.

4.13  Slot Marker Definition

1. To access these dialogs select "General > Sequence Mode > Framed (Single) /
Framed (Double)".

2. In the "Framed (Single) / Framed (Double) Configuration" tab, select "Frame:
Select Slot to configure > Slot... ".

Slot Marker Definition
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3. In the common tab, select "Burst Type".

4. In the corresponding burst type tab, select "Slot Marker Definition".

This dialog displays the structure of the slot and comprises the settings for config-
uring a ramp.

The marker signals thus defined take only effect when marker mode "As defined in
slot" is selected.

The structure of the selected slot (in the example, synchronization burst) is displayed in
the dialog header. The individual fields of the burst are color-coded.

The available marker signals are also color-coded. In the left "Configure Control Sig-
nal" section, each individual signal is assigned a color. A check in the checkbox shows
the marker for which the "As defined in slot" marker type has been selected.

In the next section, "Select Ramp to Edit", the signal characteristics are graphically dis-
played.

The ramps can be assigned the exact bit position in the signal by
● The schematic display of the slot above the section.
● The bit scale below the marker/control signal characteristic.
● The display of the current cursor position in the "Cursor" dialog section if the cursor

marks the ramp. The field at the selected position in the slot is displayed on the
side. The bit position of the cursor within this field is displayed below

The ramps can be set either graphically in the "Select Ramp to Edit" section or in the
table of the "Positions Marker x" section. To make the setting easy, a selection of pre-
set ramp characteristics is offered in the "Preset Ramp Marker x" section.

Provided are the following settings:

Configure Control Signal
Displays the color the marker and the Burst Gate signal has been assigned.

Slot Marker Definition



GSM/EDGE Configuration and SettingsR&S®SMW-K40/-K41

58User Manual 1175.6684.02 ─ 15

Displays whether the "CList" marker mode has been selected for this marker signal,
see "Marker Settings".

Displays whether the "As defined in Slot" marker mode has been selected for this
marker signal.

The source can be selected here as well and is then used in the associated dialogs.

Note: The burst gate signal is only displayed and cannot be edited.

Remote command: 
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:USER<ch>]:TRIGger:
OUTPut:TAG? on page 102

Select Ramp to Edit
Graphically edit marker signals.

For this purpose, the cursor is set to the position where a ramp is required. The ramp is
generated by pressing Enter (e.g. clicking the rotary knob). Any number of ramps can
be defined per marker. Each of the generated ramp positions is saved even if the defi-
nition of another ramp produces a low/low or high/high transition. The ramps are dis-
played as dashed lines.

Existing ramps can be shifted after the cursor has been placed on the ramp and Enter
has been pressed – it then changes color twice. The ramp is shifted by using the cur-
sor keys or the rotary knob. The new position is determined by pressing Enter again.

Ramps can be deleted with the [BACKSPACE] key after the cursor has been placed on
the ramp.

Remote command: 
n.a.

Total List Length
Displays the length of the list in bits.

Remote command: 
n.a.

Preset Type
Activates presetting for the ramp characteristic of the selected control signal. The pre-
setting is selected with select "Preset Type" and activated with the "Preset" button.

You can select from:

"All Up" The marker signal is continuously high.

"All Down" The marker signal is continuously low.

"Ramp Up" The marker signal contains a ramp from low to high. The ramp is shif-
ted to the center of the displayed signal area and can then be shifted
as required.

"Ramp Down" The marker signal contains a ramp from high to low. The ramp is shif-
ted to the center of the displayed signal area and can then be shifted
as required.

"Ramp Up/
Down"

The marker signal contains a ramp from low to high and from high to
low. The ramps are symmetrically shifted around the center of the dis-
played signal area and can then be shifted as required.

Slot Marker Definition
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"Ramp
Down/Up"

The marker signal contains a ramp from high to low and from low to
high. The ramps are symmetrically shifted around the center of the
displayed signal area and can then be shifted as required.

Remote command: 
n.a.

Edit Table
Opens table by using the "Edit Table" button.

The ramps of the selected signal can be edited in the table. When the table is opened,
the current configuration of the selected marker/control signal is displayed.

The bit position is specified in the "Ramp Position" column, the high or low signal sta-
tus in the "Ramp State" column. At the end of the list, there is always a blank row for
entering new values.

The changes are accepted in the graphic display after pressing the "Accept" button.

Remote command: 
n.a.

Cursor Position
Enters the cursor position.

In the graphic display, the cursor is positioned according to the entry.

Vice versa, graphically shifting the cursor changes the displayed value.

The field at the selected position in the slot is displayed on the side. The bit position of
the cursor within this field is displayed below.

Remote command: 
n.a.
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Zoom In/Visible
Zooms the displayed area of the control list. The designation of the button changes
from "Zoom in" to "Zoom out".

With long control lists, the displayed area can be zoomed around the current "Cursor
Position".

Parameter "Visible/Bits Visible" determines the number of symbols/bits to be displayed.

Ramps outside the displayed area are not lost by zooming.

Remote command: 
n.a.

Save
Saves the settings made in the "Slot Marker" dialog into a file with filename format
GsmMarkSlotDefP<x>F<y>S<z>U<w>.dm_iqc, where:
● x the path number,
● y is the Frame number,
● z is the Slot number and
● w is the User number.

Remote command: 
n.a.

Slot Marker Definition
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5  Remote-Control Commands
The following commands are required to perform signal generation with the GSM/
EDGE options in a remote environment. We assume that the R&S SMW has already
been set up for remote operation in a network as described in the R&S SMW docu-
mentation. A knowledge about the remote control operation and the SCPI command
syntax are assumed.

Conventions used in SCPI command descriptions
For a description of the conventions used in the remote command descriptions, see
section "Remote Control Commands" in the R&S SMW user manual.

Common suffixes

The following common suffixes are used in remote commands:

Suffix Value range Description

ENTity<ch> 1 .. 4 entity in a multiple entity configuration with separate base-
band sources

ENTity3|4 require option R&S SMW-K76

SOURce<hw> [1] to 4 available baseband signals

only SOURce1 possible, if the keyword ENTity is used

OUTPut<ch> 1 to 3 available markers

FRAMe<di> [1]|2 ● in Frame (Double) mode (SOURce:BB:GSM:MODE
DOUBle) this suffix defines the frame to which the
setting applies

● in Frame (Single) mode the keyword FRAMe is
ignored and can be omitted

SLOT<st0> 0|[1] .. 7 defines the slot to which the setting applies

Note: SCPI prescribes that suffix 1 is the default state and
used when no specific suffix is specified. Therefore, slot 1
(and not slot 0) is selected when no suffix is specified.

SUBChannel<us> [1]|2 defines the VAMOS subchannel

USER<ch> [1]|2 defines the half rate user in a half rate mode

Using SCPI command aliases for advanced mode with multiple entities
You can address multiple entities configurations by using the SCPI commands starting
with the keyword SOURce or the alias commands starting with the keyword ENTity.

Note that the meaning of the keyword SOURce<hw> changes in the second case.

For details, see section "SCPI Command Aliases for Advanced Mode with Multiple
Entities" in the R&S SMW user manual.

The following commands specific to the GSM/EDGE are described here:



Remote-Control CommandsR&S®SMW-K40/-K41

62User Manual 1175.6684.02 ─ 15

● General Commands................................................................................................62
● Save Recall Frame/Slots.........................................................................................69
● Modulation/Filter Settings........................................................................................73
● Clock Settings......................................................................................................... 80
● Trigger Settings.......................................................................................................82
● Marker Settings.......................................................................................................86
● Power Ramping/Slot Attenuation............................................................................ 89
● Burst Editor............................................................................................................. 91
● Slot Marker Definition............................................................................................102

5.1  General Commands

[:SOURce<hw>]:BB:GSM:SLENgth................................................................................... 62
[:SOURce<hw>]:BB:GSM:FLENgth....................................................................................62
[:SOURce<hw>]:BB:GSM:FONE....................................................................................... 63
[:SOURce<hw>]:BB:GSM:FRAMe<di>:REPetitions............................................................. 63
[:SOURce<hw>]:BB:GSM:ISLength................................................................................... 64
[:SOURce<hw>]:BB:GSM:MODE.......................................................................................64
[:SOURce<hw>]:BB:GSM:PRESet.....................................................................................65
[:SOURce<hw>]:BB:GSM:SATTenuation<ch>..................................................................... 65
[:SOURce<hw>]:BB:GSM:SETTing:CATalog?..................................................................... 65
[:SOURce<hw>]:BB:GSM:SETTing:DELete........................................................................ 66
[:SOURce<hw>]:BB:GSM:SETTing:LOAD.......................................................................... 66
[:SOURce<hw>]:BB:GSM:SETTing:STORe........................................................................ 66
[:SOURce<hw>]:BB:GSM:SMODe.....................................................................................67
[:SOURce<hw>]:BB:GSM:SRATe.......................................................................................67
[:SOURce<hw>]:BB:GSM:SRATe:MODE............................................................................68
[:SOURce<hw>]:BB:GSM:STATe....................................................................................... 68
[:SOURce<hw>]:BB:GSM:WAVeform:CREate..................................................................... 68

[:SOURce<hw>]:BB:GSM:SLENgth <SLength>
[:SOURce<hw>]:BB:GSM:FLENgth <FLength>

Sets the sequence length of the generated arbitrary waveform file in number of frames.
This parameter applies to GSM modes Single or Double framed.

For GSM mode Framed Double, this command is query only, since the length of the
generated ARB file is determined by the parameter Frame Repetition ([:
SOURce<hw>]:BB:GSM:FRAMe<di>:REPetitions) for both frames:

Sequence Length = Frame Repetition of Frame 1 + Frame Repetition of Frame 2.

For GSM mode (BB:GSM:MODE) set to Unframed, the length of the generated ARB file
is set in symbols with the command [:SOURce<hw>]:BB:GSM:SLENgth.

Parameters:
<FLength> integer

Range: 1  to  max

General Commands
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Example: BB:GSM:MODE SING
Selects framed single GSM mode.
BB:GSM:FLEN 2
Sets the sequence length to two frames.
BB:GSM:MODE DOUB
Selects framed double GSM mode.
BB:GSM:FRAM1:REP 2
Sets the frame repetition of frame 1 to 2.
BB:GSM:FRAM2:REP 1
Sets the frame repetition of frame 2 to 1.
BB:GSM:FLEN?
Queries the sequence length.
Response: 3

Manual operation: See "Sequence Length ARB" on page 40

[:SOURce<hw>]:BB:GSM:FONE <FOne>

A modulating bit stream consisting of consecutive ones is used for inactive slots
(according to GSM 05.04).

If this parameter is disabled, the inactive slots are filled in with 0.

Parameters:
<FOne> 0 | 1 | OFF | ON

*RST: OFF

Example: BB:GSM:FONE ON
A modulating bit stream consisting of consecutive ones is used
for inactive slots.

Manual operation: See " Force Dummy Bits to 1 " on page 32

[:SOURce<hw>]:BB:GSM:FRAMe<di>:REPetitions <Repetitions>

The command defines the number of repetitions for the selected frame in GSM mode
Frame (Double).

Parameters:
<Repetitions> integer

Range: 1  to  500000
*RST: 1 / 1

Example: BB:GSM:MODE DOUB
selects GSM mode Frame (Double).
BB:GSM:FRAM2:REP 10
sets 10 repetitions for frame 2.

Manual operation: See " Frame Repetition " on page 28

General Commands
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[:SOURce<hw>]:BB:GSM:ISLength <ISLength>

Selects constant slot length.

Parameters:
<ISLength> 0 | 1 | OFF | ON

For normal symbol rate mode:
The command selects whether the 1/4 symbol of a GSM slot is
ignored or compensated for by an extra symbol every 4th slot.
For higher symbol rate mode:
The command selects whether the 1/2 symbol of an average slot
with a length of 187.5 symbols are ignored or compensated for
by an extra symbol every second slot.
ON
In normal symbol rate mode, all slots are 156 symbols long
In higher symbol rate mode, all slots are 187 symbols long
OFF
In normal symbol rate mode, some slots are 157 symbols long
In higher symbol rate mode, some slots are 188 symbols long
*RST: 0

Example: BB:GSM:SRAT:MODE NSR
Selects normal symbol rate mode.
BB:GSM:ISL ON
Selects a constant length of 156 symbols for all slots.

Manual operation: See " Ignore 1/4 symbol (slot length 156 sym) / Ignore ½ symbol
(slot length 187 sym) " on page 32

[:SOURce<hw>]:BB:GSM:MODE <Mode>

The command selects GSM mode.

Parameters:
<Mode> UNFRamed | SINGle | DOUBle | MULTiframe

UNFRamed
Modulation signal without slot and frame structure.
SINGle
Modulation signal consisting of one frame.
DOUBle
Modulation signal in which two frames are defined and then
combined by some method into a single multiframe signal.
MULTiframe
Multiframe signal.
*RST: SINGle

Example: BB:GSM:MODE SING
sets the "Single Frame" GSM mode. Only the commands for
defining a single frame are valid.

General Commands
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Manual operation: See "Sequence Mode" on page 15

[:SOURce<hw>]:BB:GSM:PRESet

Sets the parameters of the digital standard to their default values (*RST values speci-
fied for the commands).

Not affected is the state set with the command SOURce<hw>:BB:GSM:STATe.

Example: SOURce1:BB:GSM:PRESet
Usage: Event

Manual operation: See "Set to Default" on page 14

[:SOURce<hw>]:BB:GSM:SATTenuation<ch> <SAttenuation>

The command sets up to seven different values for level attenuation. The various val-
ues are defined by the suffix to SATTenuation. These values are used when defining
the level attenuation of individual slots with the aid of the command [:SOURce<hw>]:
BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:USER<ch>]:
ATTenuation.

Parameters:
<SAttenuation> float

Range: 0  to  60 dB
Increment: 0.01 dB
*RST: 0 dB

Example: BB:GSM:MODE SING
Selects GSM mode Frame (Single).
BB:GSM:SLOT1:LEV ATT
Sets level attenuation mode for slot 1.
BB:GSM:SATT1 12dB
Sets the level attenuation for selection A1 to 12 dB.
BB:GSM:SLOT1:ATT A1
Sets the level attenuation for slot 1 dB to 12 dB.

Manual operation: See " Slot Attenuation A1 to A7 " on page 43

[:SOURce<hw>]:BB:GSM:SETTing:CATalog?

This command reads out the files with GSM settings in the default directory. The
default directory is set using command MMEM:CDIRectory. Only files with the file
extension *.gsm are listed.

Return values: 
<Catalog> string

General Commands



Remote-Control CommandsR&S®SMW-K40/-K41

66User Manual 1175.6684.02 ─ 15

Example: MMEM:CDIR "/var/user/temp/dig_mod
Sets the default directory to /var/user/temp/dig_mod.
BB:GSM:SETT:CAT?
Reads out all the files with GSM settings in the default directory.
Response: gsm_1

Usage: Query only

Manual operation: See "Save/Recall" on page 15

[:SOURce<hw>]:BB:GSM:SETTing:DELete <Filename>

This command deletes the selected file with GSM settings. The directory is set using
command MMEM:CDIRectory. A path can also be specified, in which case the files in
the specified directory are read. The file extension can be omitted. Only files with the
file extension *.gsm are deleted.

Setting parameters: 
<Filename> string

Example: BB:GSM:SETT:DEL 'gsm_1'
Deletes file gsm_1.

Usage: Setting only

Manual operation: See "Save/Recall" on page 15

[:SOURce<hw>]:BB:GSM:SETTing:LOAD <Filename>

This command loads the selected file with GSM settings. The directory is set using
command MMEM:CDIRectory. A path can also be specified, in which case the files in
the specified directory are read. The file extension can be omitted. Only files with the
file extension *.gsm are loaded.

Setting parameters: 
<Filename> string

Example: BB:GSM:SETT:LOAD 'gsm_1'
Loads file gsm_1

Usage: Setting only

Manual operation: See "Save/Recall" on page 15

[:SOURce<hw>]:BB:GSM:SETTing:STORe <Filename>

This command stores the current GSM settings into the selected file. The directory is
set using command MMEM:CDIRectory. A path can also be specified, in which case
the files in the specified directory are read. Only enter the file name. GSM settings are
stored as files with the specific file extensions *.gsm.

Setting parameters: 
<Filename> string

General Commands
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Example: BB:GSM:SETT:STOR 'gsm_1'
Stores the current GSM settings into file gsm_1.

Usage: Setting only

Manual operation: See "Save/Recall" on page 15

[:SOURce<hw>]:BB:GSM:SMODe <SMode>

Selects the modulation signal for the mode Unframed (:BB:GSM:MODE UNFR). The
modulation type and filter type are set in accordance with the selection.

The available simulation modes depend on the selected symbol rate:
● Normal Symbol Rate - GSM, EDGE (8PSK), AQPSK, 16QAM and 32QAM
● Higher Symbol Rate - HSR QPSK, HSR 16QAM and HSR 32QAM.

Note:"Higher Symbol Rate" Mode and "Simulation Modes" AQPSK, 16QAM, 32QAM,
HSR QPSK, HSR 16QAM and HSR 32QAM are available for instruments equipped
with option R&S SMW-K41 only.

Parameters:
<SMode> GSM | EDGE | N16Qam | N32Qam | HQPSk | H16Qam |

H32Qam | AQPSk
*RST: GSM

Example: BB:GSM:MODE UNFR
Sets unframed mode.
BB:GSM:SRAT:MODE HSR
Selects higher symbol rate mode.
BB:GSM:SMOD H16Q
Selects an HSR 16QAM modulation signal for the Unframed
mode.
BB:GSM:SRAT:MODE NSR
Selects normal symbol rate mode.
BB:GSM:SMOD GSM
Selects a GSM modulation signal for the Unframed mode.

Options: R&S SMW-K41 (required for N16Qam | N32Qam | HQPSk |
H16Qam | H32Qam | AQPSk)

Manual operation: See " Simulation Mode " on page 15

[:SOURce<hw>]:BB:GSM:SRATe <SRate>

Sets the symbol clock. Possible units are Hz, kHz, MHz, Sym/s, kSym/s, MSym/s.

Parameters:
<SRate> float

Range: 400  to  15000000
Increment: 0.001
*RST: 270.833 kSym/s

General Commands
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Example: BB:GSM:SRAT 270.9 kHz
sets the symbol clock to 270.9 kHz.

Manual operation: See " Symbol Rate " on page 32

[:SOURce<hw>]:BB:GSM:SRATe:MODE <Mode>

Set the symbol rate mode, i.e. determines whether normal bursts (NB) or higher sym-
bol rate bursts (HB) are generated.

Parameters:
<Mode> NSRate | HSRate

*RST: NSRate

Example: BB:GSM:SRAT HSR
Selects higher symbol rate mode
BB:GSM:SRAT?
Queries the symbol clock.
Response: 325

Options: (for instruments equipped with option K41 only)

Manual operation: See "Symbol Rate Mode" on page 15

[:SOURce<hw>]:BB:GSM:STATe <State>

Activates the standard and deactivates all the other digital standards and digital modu-
lation modes in the same path.

Parameters:
<State> 0 | 1 | OFF | ON

*RST: 0

Example: SOURce1:BB:GSM:STATe ON
Manual operation: See "State" on page 13

[:SOURce<hw>]:BB:GSM:WAVeform:CREate <Filename>

Creates a waveform using the current settings of GSM/EDGE. The file name is entered
with the command. The file is stored with the predefined file extension *.wv. The file
name and the directory it is stored in are user-definable.

Setting parameters: 
<Filename> string

Example: MMEM:CDIR '/var/user/temp/waveform'
sets the default directory to /var/user/temp/waveform.
BB:GSM:WAV:CRE 'gsm_1'
creates the waveform file gsm.wv in the default directory.

Usage: Setting only

Manual operation: See "Generate Waveform File…" on page 15

General Commands
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5.2  Save Recall Frame/Slots

[:SOURce<hw>]:BB:GSM:FRAMe<di>:ULISt:CATalog?....................................................... 69
[:SOURce<hw>]:BB:GSM:FRAMe<di>:ULISt:DELete.......................................................... 69
[:SOURce<hw>]:BB:GSM:FRAMe<di>:ULISt:LOAD............................................................ 70
[:SOURce<hw>]:BB:GSM:FRAMe<di>:ULISt:STORe...........................................................70
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:PREDefined:CATalog?............................................70
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:PREDefined:LOAD.................................................71
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:USER<ch>]:

PREDefined:CATalog?............................................................................................71
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:USER<ch>]:

PREDefined:LOAD.................................................................................................72
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:USER<ch>]:

ULISt:CATalog?..................................................................................................... 72
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:USER<ch>]:

ULISt:DELete........................................................................................................ 72
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:USER<ch>]:

ULISt:LOAD.......................................................................................................... 73
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:USER<ch>]:

ULISt:STORe........................................................................................................ 73

[:SOURce<hw>]:BB:GSM:FRAMe<di>:ULISt:CATalog?

This command reads out the files with user defined frame settings in the default direc-
tory. The default directory is set using command MMEM:CDIRectory. Only files with
the file extension *.gsm_fu and *.gsm_hfu are listed.

Return values: 
<Catalog> string

Example: MMEM:CDIR "/var/user/temp/frames"
Sets the default directory to /var/user/temp/frames.
BB:GSM:FRAM:ULIS:CAT?
Reads out all the files with user defined frame settings in the
default directory.
Response: 'NB_all'
The file NB_all with a user defined frame setting is available.

Usage: Query only

Manual operation: See " Recall User Files " on page 30

[:SOURce<hw>]:BB:GSM:FRAMe<di>:ULISt:DELete <Filename>

This command deletes the selected file with user defined frame settings. The directory
is set using command MMEM:CDIRectory. A path can also be specified, in which
case the files in the specified directory are read. The file extension can be omitted.
Only files with the file extension *.gsm_fu and *.gsm_hfu are deleted.

Setting parameters: 
<Filename> string

Save Recall Frame/Slots
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Example: BB:GSM:FRAM:ULIS:DEL 'NB_all'
Deletes file NB_all.

Usage: Setting only

Manual operation: See " File Manager " on page 30

[:SOURce<hw>]:BB:GSM:FRAMe<di>:ULISt:LOAD <Filename>

This command loads the selected file with user defined frame settings. The directory is
set using command MMEM:CDIRectory. A path can also be specified, in which case
the files in the specified directory are read. The file extension can be omitted. Only files
with the file extension *.gsm_fu and *.gsm_hfu are loaded.

Setting parameters: 
<Filename> string

Example: BB:GSM:FRAM:ULIS:LOAD 'NB_all'
Loads file NB_all.

Usage: Setting only

Manual operation: See " Recall User Files " on page 30

[:SOURce<hw>]:BB:GSM:FRAMe<di>:ULISt:STORe <Filename>

This command stores the current frame settings into the selected file. The directory is
set using command MMEM:CDIRectory. A path can also be specified, in which case
the files in the specified directory are read. Only enter the file name. User Standards
are stored as files with the specific file extensions *.gsm_fu and *.gsm_hfu.

Setting parameters: 
<Filename> string

Example: BB:GSM:FRAM:ULIS:STOR 'EDGE_all'
Stores the current frame settings into file EDGE_all.

Usage: Setting only

Manual operation: See " Save User Files " on page 30

[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:PREDefined:CATalog?

This command reads out the files with predefined frame settings. The directory is pre-
set, therefore a path cannot be specified.

Return values: 
<Catalog> string
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Example: BB:GSM:FRAM:PRED:CAT?
reads out all the files with predefined frame settings.
Response: 'Edge0, EdgeAll, GsmEdge,
NormalBurst0, NormalBurstAll'
the file names of the files with the predefined frame settings are
returned

Usage: Query only

Manual operation: See " Recall Predefined Files " on page 29

[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:PREDefined:LOAD <Filename>

This command loads the selected file with predefined frame settings. The directory is
pre-set, therefore a path cannot be specified.

Setting parameters: 
<Filename> string

Example: BB:GSM:MODE SING
selects GSM mode Frame (Single).
BB:GSM:SRAT:MODE NSR
selects normal symbol rate.
BB:GSM:FRAM:PRED:LOAD 'Edge0'
loads file Edge0 with the predefined frame setting Edge Burst in
Slot 0.

Usage: Setting only

Manual operation: See " Recall Predefined Files " on page 29

[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>]:PREDefined:CATalog?

This command reads out the files with predefined slot settings. The directory is preset,
therefore a path cannot be specified.

The numeric suffixes in all key words are irrelevant for this command.

Return values: 
<Catalog> string

Example: BB:GSM:SLOT:PRED:CAT?
reads out all the files with predefined frame settings.
Response: GSM_NB_PN9_TSC0,EDGE_NB_PN9_TSC0
the files GSM_NB_PN9_TSC0 and EDGE_NB_PN9_TSC0 are
available.

Usage: Query only

Manual operation: See " Recall Predefined Files " on page 29
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[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>]:PREDefined:LOAD <Filename>

This command loads the selected file with predefined slot settings. The directory is pre-
set, therefore a path cannot be specified.

Setting parameters: 
<Filename> string

Example: BB:GSM:SLOT:PRED:LOAD 'GSM_NB_PN9_TSC0'
loads the settings of file GSM_NB_PN9_TSC0 for slot 1 in frame
1.

Usage: Setting only

Manual operation: See " Recall Predefined Files " on page 29

[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>]:ULISt:CATalog?

This command reads out the files with user defined slot settings in the default directory.
The default directory is set using command MMEM:CDIRectory. Only files with the file
extension *.gsm_slu and *.gsm_hslu are listed.

Return values: 
<Catalog> string

Example: MMEM:CDIR '/var/user/temp/slots
Sets the default directory to /var/user/temp/slots.
BB:GSM:SLOT:ULIS:CAT?
Reads out all the files with user defined slot settings in the
default directory.
Response: 'test_01'
The file test_01 with a user defined slot setting is available.

Usage: Query only

Manual operation: See " Recall User Files " on page 30

[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>]:ULISt:DELete <Filename>

This command deletes the selected file with user defined slot settings. The directory is
set using command MMEM:CDIRectory. A path can also be specified, in which case
the files in the specified directory are read. The file extension can be omitted. Only files
with the file extension *.gsm_slu and *.gsm_hslu are deleted.

Setting parameters: 
<Filename> string

Example: BB:GSM:SLOT:ULIS:DEL 'NB'
Deletes file NB.

Usage: Setting only
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Manual operation: See " File Manager " on page 30

[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>]:ULISt:LOAD <Filename>

This command loads the selected file with user defined slot settings. The directory is
set using command MMEM:CDIRectory. A path can also be specified, in which case
the files in the specified directory are read. The file extension can be omitted. Only files
with the file extension *.gsm_slu and *.gsm_hslu are loaded.

Setting parameters: 
<Filename> string

Example: BB:GSM:SLOT:ULIS:LOAD 'NB'
Loads file NB.

Usage: Setting only

Manual operation: See " Recall User Files " on page 30

[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>]:ULISt:STORe <Filename>

This command stores the current slot settings into the selected file. The directory is set
using command MMEM:CDIRectory. A path can also be specified, in which case the
files in the specified directory are read. Only enter the file name. User slots are stored
as files with the specific file extensions *.gsm_slu and *.gsm_hslu.

Setting parameters: 
<Filename> string

Example: BB:GSM:SLOT:ULIS:STOR 'EDGE'
Stores the current slot settings into file EDGE.

Usage: Setting only

Manual operation: See " Save User Files " on page 30

5.3  Modulation/Filter Settings

5.3.1  Modulation Settings

[:SOURce<hw>]:BB:GSM:FORMat.................................................................................... 74
[:SOURce<hw>]:BB:GSM:EDGE:FORMat?........................................................................ 74
[:SOURce<hw>]:BB:GSM:FSK:DEViation...........................................................................74
[:SOURce<hw>]:BB:GSM:AQPSk:FORMat?.......................................................................75
[:SOURce<hw>]:BB:GSM:H16Qam:FORMat?.....................................................................75
[:SOURce<hw>]:BB:GSM:H32Qam:FORMat?.....................................................................75
[:SOURce<hw>]:BB:GSM:HQPSk:FORMat?.......................................................................76
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[:SOURce<hw>]:BB:GSM:N16Qam:FORMat?.....................................................................76
[:SOURce<hw>]:BB:GSM:N32Qam:FORMat?.....................................................................77
[:SOURce<hw>]:BB:GSM:AQPSk:ANGLe<ch0>................................................................. 77
[:SOURce<hw>]:BB:GSM:AQPSk:SCPIR<ch0>.................................................................. 77

[:SOURce<hw>]:BB:GSM:FORMat <Format>

The command selects the modulation type.

Parameters:
<Format> MSK | FSK2

*RST: MSK

Example: BB:GSM:FORM FSK2
selects the GSM modulation type FSK.

Manual operation: See " Modulation " on page 33

[:SOURce<hw>]:BB:GSM:EDGE:FORMat?

The command queries the modulation type in the case of EDGE. The modulation type
is permanently set to 8PSK.

Return values: 
<Format> P8EDge

*RST: P8EDge

Example: BB:GSM:EDGE:FORM?
queries the modulation type.
Response: "P8ED"

Usage: Query only

Manual operation: See " Modulation Type EDGE " on page 35

[:SOURce<hw>]:BB:GSM:FSK:DEViation <Deviation>

Sets the modulation deviation when :BB:GSM:FORMat FSK2 is selected.

The range of values depends on the symbol rate (:BB:GSM:SRATe). The maximum
deviation is 10 MHz.

Parameters:
<Deviation> float

Range: 0.1xf(symb)  to  1.5xf(symb);(10MHz)
Increment: 0.1
*RST: 67708.3333
Default unit: Hz

Example: BB:GSM:FORM FSK2
selects the GSM modulation type GFSK.
BB:GSM:FSK:DEV 37.6 kHz
sets the FSK deviation to 37.6 kHz.
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Manual operation: See " FSK Deviation " on page 33

[:SOURce<hw>]:BB:GSM:AQPSk:FORMat?

The command queries the modulation type. The modulation type is permanently set to
AQPSK.

Return values: 
<Format> AQPSk

*RST: AQPSk

Example: BB:GSM:AQPS:FORM?
queries the modulation type.
Response: "AQPSk"

Usage: Query only

Options: R&S SMW-K41

Manual operation: See "Modulation AQPSK" on page 34

[:SOURce<hw>]:BB:GSM:H16Qam:FORMat?

The command queries the modulation type.

Return values: 
<Format> QAM16EDge

*RST: QAM16EDge

Example: BB:GSM:SRAT:MODE HSR
selects higher symbol rate mode.
BB:GSM:H16Q:FORM?
queries the modulation type.
Response: "QAM16ED"

Usage: Query only

Options: (for Higher Symbol Rate and instruments equipped with option
K41 only)

Manual operation: See " Modulation Type HSR 16QAM " on page 39

[:SOURce<hw>]:BB:GSM:H32Qam:FORMat?

The command queries the modulation type.

Return values: 
<Format> QAM32EDge

*RST: QAM32EDge
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Example: BB:GSM:SRAT:MODE HSR
selects higher symbol rate mode.
BB:GSM:H32Q:FORM?
queries the modulation type.
Response: QAM32ED

Usage: Query only

Options: (for Higher Symbol Rate and instruments equipped with option
K41 only)

Manual operation: See " Modulation Type HSR 32QAM " on page 39

[:SOURce<hw>]:BB:GSM:HQPSk:FORMat?

The command queries the modulation type.

Return values: 
<Format> QEDGe

*RST: QEDGe

Example: BB:GSM:SRAT:MODE HSR
selects higher symbol rate mode.
BB:GSM:HQPS:FORM?
queries the modulation type.
Response: QQDG

Usage: Query only

Options: (for Higher Symbol Rate and instruments equipped with option
K41 only)

Manual operation: See " Modulation Type HSR QPSK " on page 38

[:SOURce<hw>]:BB:GSM:N16Qam:FORMat?

The command queries the modulation type.

Return values: 
<Format> QAM16EDge

*RST: QAM16EDge

Example: BB:GSM:SRAT:MODE NSR
selects normal symbol rate mode.
BB:GSM:N16Q:FORM?
queries the modulation type.
Response: QAM16ED

Usage: Query only

Options: (for instruments equipped with option K41 only)

Manual operation: See " Modulation Type 16QAM " on page 36
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[:SOURce<hw>]:BB:GSM:N32Qam:FORMat?

The command queries the modulation type.

Return values: 
<Format> QAM32EDge

*RST: QAM32EDge

Example: BB:GSM:SRAT:MODE NSR
selects normal symbol rate mode.
BB:GSM:N32Q:FORM?
queries the modulation type.
Response: QAM32ED

Usage: Query only

Options: (for instruments equipped with option K41 only)

Manual operation: See " Modulation Type 32QAM " on page 37

[:SOURce<hw>]:BB:GSM:AQPSk:ANGLe<ch0> <Angle>

Sets the angle alpha.

Parameters:
<Angle> float

Range: 0.0001  to  89.9999
Increment: 0.0001
*RST: 45

Example: BB:GSM:AQPS:ANGL5 50
Options: R&S SMW-K41

Manual operation: See "Angle alpha_0 ... alpha_7" on page 34

[:SOURce<hw>]:BB:GSM:AQPSk:SCPIR<ch0> <Scpir>

Sets the Subchannel Power Imbalance Ratio (SCPIR). It is related to the angle α as
follows:

SCPIR = 20 * log10(tan α) dB,

where the value of α is chosen such that |SCPIR|≤10dB.

Parameters:
<Scpir> float

Range: -115.1625  to  115.1625
Increment: 0.0001
*RST: 0

Example: BB:GSM:AQPS:SCPIR5 -10
BB:GSM:AQPS:ANGL5?
Response: 17.5484
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Options: R&S SMW-K41

Manual operation: See "SCPIR_0 to SCPIR_7" on page 35

5.3.2  Filter Settings

[:SOURce<hw>]:BB:GSM:FILTer:TYPE?............................................................................ 78
[:SOURce<hw>]:BB:GSM:FILTer:PARameter...................................................................... 78
[:SOURce<hw>]:BB:GSM:FILTer:AQPSK:TYPE?................................................................ 79
[:SOURce<hw>]:BB:GSM:FILTer:EDGE:TYPE?.................................................................. 79
[:SOURce<hw>]:BB:GSM:FILTer:N16Qam:TYPE?.............................................................. 79
[:SOURce<hw>]:BB:GSM:FILTer:N32Qam:TYPE?.............................................................. 79
[:SOURce<hw>]:BB:GSM:FILTer:H16Qam:TYPE................................................................ 80
[:SOURce<hw>]:BB:GSM:FILTer:H32Qam:TYPE................................................................ 80
[:SOURce<hw>]:BB:GSM:FILTer:HQPSk:TYPE.................................................................. 80

[:SOURce<hw>]:BB:GSM:FILTer:TYPE?

The command sets the filter type GAUSs. This is the only possible selection in the
case of digital standard GSM.

Return values: 
<Type> GAUSs

*RST: GAUSs

Example: BB:GSM:FILT:TYPE GAUS
sets the filter type GAUSS.

Usage: Query only

Manual operation: See " Filter " on page 33

[:SOURce<hw>]:BB:GSM:FILTer:PARameter <Parameter>

The command sets the filter parameter. For Gaussian filter the BxT is the product of
the bandwidth and the symbol duration. The default value for GSM modulation is 0.3
and for Gauss Linearized (EDGE), BT = 0.3.

Parameters:
<Parameter> float

Range: 0.15  to  2.5
Increment: 0.01
*RST: 0.3

Example: BB:GSM:FILT:PAR 0.4
sets the BT value to 0.4.

Manual operation: See " Filter Parameter " on page 34
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[:SOURce<hw>]:BB:GSM:FILTer:AQPSK:TYPE?

Queries the filter type for AQPSK modulation. The filter is permanently set to GAUSS
linearized.

Return values: 
<Type> LGAuss

*RST: LGAuss

Usage: Query only

Options: R&S SMW-K41

Manual operation: See " Filter " on page 35

[:SOURce<hw>]:BB:GSM:FILTer:EDGE:TYPE?

The command sets the filter type LGAuss. This is the only possible selection in the
case of digital standard GSM EDGE.

Return values: 
<Type> LGAuss

*RST: LGAuss

Example: BB:GSM:FILT:EDGE:TYPE LGA
sets the filter type Gauss linearized.

Usage: Query only

Manual operation: See " Filter " on page 36

[:SOURce<hw>]:BB:GSM:FILTer:N16Qam:TYPE?

Queries filter for 16QAM signal. The filter is permanently set to GAUSS linearized.

Return values: 
<Type> LGAuss

Example: BB:GSM:FILT:N16Q:TYPE?
queries the filter type.
Response: LGA

Usage: Query only

Options: K41

Manual operation: See " Filter " on page 36

[:SOURce<hw>]:BB:GSM:FILTer:N32Qam:TYPE?

Queries filter for 32QAM signal. The filter is permanently set to GAUSS linearized.

Return values: 
<Type> LGAuss
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Example: BB:GSM:FILT:N32Q:TYPE?
queries the filter type.
Response: LGA

Usage: Query only

Options: K41

Manual operation: See " Filter " on page 37

[:SOURce<hw>]:BB:GSM:FILTer:H16Qam:TYPE <Type>

Sets the filter for HSR 16QAM signal.

Parameters:
<Type> ENPShape | EWPShape

*RST: ENPShape

Example: BB:GSM:FILT:H16Q:TYPE ENPS

[:SOURce<hw>]:BB:GSM:FILTer:H32Qam:TYPE <Type>

Sets the filter for HSR 32QAM signal.

Parameters:
<Type> ENPShape | EWPShape

*RST: ENPShape

Example: BB:GSM:FILT:H32Q:TYPE ENPS
Manual operation: See " Filter " on page 39

[:SOURce<hw>]:BB:GSM:FILTer:HQPSk:TYPE <Type>

Sets the filter for HSR QPSK signal.

Parameters:
<Type> ENPShape | EWPShape

*RST: ENPShape

Example: BB:GSM:FILT:HQPS:TYPE ENPS
Manual operation: See " Filter " on page 38

5.4  Clock Settings

This section lists the remote control commands, necessary to configure the clock.

[:SOURce<hw>]:BB:GSM:CLOCk:MODE........................................................................... 81
[:SOURce<hw>]:BB:GSM:CLOCk:SOURce........................................................................ 81
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[:SOURce<hw>]:BB:GSM:CLOCk:MODE <Mode>

Sets the type of externally supplied clock.

Parameters:
<Mode> SYMBol

*RST: SYMBol

Example: SOURce1:BB:GSM:CLOCk:MODE SYMBol
Options: R&S SMW-B10

Manual operation: See " Clock Mode " on page 23

[:SOURce<hw>]:BB:GSM:CLOCk:SOURce <Source>

Selects the clock source:
● INTernal: Internal clock reference
● ELCLock: External local clock
● EXTernal = ELCLock: Setting only

Provided for backward compatibility with other Rohde & Schwarz signal generators

Parameters:
<Source> INTernal|ELCLock|EXTernal

*RST: INTernal

Example: SOURce1:BB:GSM:CLOCk:SOURce INT
Options: ELCLock requires R&S SMW-B10

Manual operation: See "Clock Source" on page 23
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5.5  Trigger Settings

Example: Trigger configuration
SOURce1:BB:GSM:TRIGger:SOURce INTernal
SOURce1:BB:GSM:TRIGger:SEQuence ARETrigger
SOURce1:BB:GSM:STAT ON
SOURce1:BB:GSM:TRIGger:EXECute
SOURce1:BB:GSM:TRIGger:ARM:EXECute
SOURce1:BB:GSM:TRIGger:RMODe?
// stopped
SOURce1:BB:GSM:TRIGger:EXECute
SOURce1:BB:GSM:TRIGger:RMODe?
// run

// SOURce1:BB:GSM:TRIGger:SEQuence SING
// SOURce1:BB:GSM:TRIGger:SLUNit FRAMe
// SOURce1:BB:GSM:TRIGger:SLENgth 2

// SOURce1:BB:GSM:TRIGger:SEQuence ARET
// SOURce1:BB:GSM:TRIGger:SOURce EGT1
// SOURce1:BB:GSM:TRIGger:EXTernal:SYNChronize:OUTPut 1
// SOURce1:BB:GSM:TRIGger:EXTernal:INHibit 100
// SOURce1:BB:GSM:TRIGger:EXTernal:DELay 10

[:SOURce<hw>]:BB:GSM[:TRIGger]:SEQuence..................................................................82
[:SOURce<hw>]:BB:GSM:TRIGger:ARM:EXECute..............................................................83
[:SOURce<hw>]:BB:GSM:TRIGger:EXECute......................................................................83
[:SOURce<hw>]:BB:GSM:TRIGger:EXTernal:SYNChronize:OUTPut.....................................83
[:SOURce<hw>]:BB:GSM:TRIGger:OBASeband:DELay...................................................... 83
[:SOURce<hw>]:BB:GSM:TRIGger:OBASeband:INHibit.......................................................84
[:SOURce<hw>]:BB:GSM:TRIGger:RMODe?......................................................................84
[:SOURce<hw>]:BB:GSM:TRIGger:SLENgth...................................................................... 84
[:SOURce<hw>]:BB:GSM:TRIGger:SLUNit.........................................................................84
[:SOURce<hw>]:BB:GSM:TRIGger:SOURce...................................................................... 85
[:SOURce<hw>]:BB:GSM:TRIGger[:EXTernal]:DELay..........................................................85
[:SOURce<hw>]:BB:GSM:TRIGger[:EXTernal]:INHibit..........................................................85

[:SOURce<hw>]:BB:GSM[:TRIGger]:SEQuence <Sequence>

Selects the trigger mode:
● AUTO = auto
● RETRigger = retrigger
● AAUTo = armed auto
● ARETrigger = armed retrigger
● SINGle = single
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Parameters:
<Sequence> AUTO | RETRigger | AAUTo | ARETrigger | SINGle

*RST: AUTO

Example: See Example "Trigger configuration" on page 82

Manual operation: See "Trigger Mode" on page 17

[:SOURce<hw>]:BB:GSM:TRIGger:ARM:EXECute

Stops signal generation; a subsequent trigger event restarts signal generation.

Example: See Example "Trigger configuration" on page 82

Usage: Event

Manual operation: See "Arm" on page 18

[:SOURce<hw>]:BB:GSM:TRIGger:EXECute

Executes a trigger.

Example: See Example "Trigger configuration" on page 82

Usage: Event

Manual operation: See "Execute Trigger" on page 18

[:SOURce<hw>]:BB:GSM:TRIGger:EXTernal:SYNChronize:OUTPut <Output>

Enables signal output synchronous to the trigger event.

Parameters:
<Output> 0 | 1 | OFF | ON

*RST: 1

Example: See Example "Trigger configuration" on page 82

Manual operation: See "Sync. Output to External Trigger/Sync. Output to Trigger"
on page 19

[:SOURce<hw>]:BB:GSM:TRIGger:OBASeband:DELay <Delay>

Specifies the trigger delay for triggering by the signal from the other baseband.

Parameters:
<Delay> float

Range: 0  to  2147483647
Increment: 0.01
*RST: 0

Example: SOURce1:BB:GSM:TRIGger:SOURce INTB
SOURce1:BB:GSM:TRIGger:OBASeband:INHibit 100
SOURce1:BB:GSM:TRIGger:OBASeband:DELay 10
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Manual operation: See "Trigger Delay" on page 20

[:SOURce<hw>]:BB:GSM:TRIGger:OBASeband:INHibit <Inhibit>

For triggering via the other path, specifies the duration by which a restart is inhibited.

Parameters:
<Inhibit> integer

Range: 0  to  67108863
*RST: 0

Example: See [:SOURce<hw>]:BB:GSM:TRIGger:OBASeband:DELay
on page 83

Manual operation: See "External Trigger Inhibit" on page 20

[:SOURce<hw>]:BB:GSM:TRIGger:RMODe?

Queries the signal generation status.

Return values: 
<RMode> STOP | RUN

Example: See Example "Trigger configuration" on page 82

Usage: Query only

Manual operation: See "Running/Stopped" on page 18

[:SOURce<hw>]:BB:GSM:TRIGger:SLENgth <SLength>

Defines the length of the signal sequence that is output in the SINGle trigger mode.

Parameters:
<SLength> integer

Range: 1  to  max
*RST: 1

Example: See Example "Trigger configuration" on page 82

Manual operation: See "Trigger Signal Duration" on page 18

[:SOURce<hw>]:BB:GSM:TRIGger:SLUNit <SLunit>

Defines the unit for the entry of the signal sequence length.

Parameters:
<SLunit> FRAMe | SYMBol

*RST: FRAMe

Example: See Example "Trigger configuration" on page 82

Manual operation: See "Signal Duration Unit" on page 18
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[:SOURce<hw>]:BB:GSM:TRIGger:SOURce <Source>

Selects the trigger signal source and determines the way the triggering is executed.
Provided are:
● Internal triggering by a command (INTernal)
● External trigger signal via one of the local or global connectors

– EGT1|EGT2: External global trigger

– EGC1|EGC2: External global clock

– ELTRigger: External local trigger

– ELCLock: External local clock
● Internal triggering by a signal from the other basebands (INTA|INTB)
● In master-slave mode, the external baseband synchronization signal (BBSY)
● OBASeband|BEXTernal|EXTernal: Setting only

Provided only for backward compatibility with other Rohde & Schwarz signal gener-
ators.
The R&S SMW accepts these values and maps them automatically as follows:
EXTernal = EGT1, BEXTernal = EGT2, OBASeband = INTA or INTB
(depending on the current baseband)

Parameters:
<Source> INTB|INTernal|OBASeband|EGT1|EGT2|EGC1|EGC2|ELTRig-

ger|INTA|ELCLock|BEXTernal|EXTernal | BBSY
*RST: INTernal

Example: See Example "Trigger configuration" on page 82

Options: ELTRigger|ELCLock require R&S SMW-B10
BBSY require R&S SMW-B9

Manual operation: See "Trigger Source" on page 19

[:SOURce<hw>]:BB:GSM:TRIGger[:EXTernal]:DELay <Delay>

Sets the trigger delay.

Parameters:
<Delay> float

Range: 0  to  2147483647
Increment: 0.01
*RST: 0
Default unit: samples

Example: See Example "Trigger configuration" on page 82.

Manual operation: See "Trigger Delay" on page 20

[:SOURce<hw>]:BB:GSM:TRIGger[:EXTernal]:INHibit <Inhibit>

Specifies the duration by which a restart is inhibited.
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Parameters:
<Inhibit> integer

Range: 0  to  21.47*symbRate
*RST: 0

Example: See Example "Trigger configuration" on page 82.

Manual operation: See "External Trigger Inhibit" on page 20

5.6  Marker Settings

Example: Marker configuration
SOURce1:BB:GSM:TRIGger:OUTPut1:MODE PULS
// sets a pulse marker
SOURce1:BB:GSM:TRIGger:OUTPut1:PULSe:DIVider 2
SOURce1:BB:GSM:TRIGger:OUTPut1:PULSe:FREQuency?

SOURce1:BB:GSM:TRIGger:OUTPut1:MODE PATTern
// sets a bit pattern marker
SOURce1:BB:GSM:TRIGger:OUTPut1:PATTern #H2,2

SOURce1:BB:GSM:TRIGger:OUTPut1:MODE RAT
SOURce1:BB:GSM:TRIGger:OUTPut1:ONTime 1
SOURce1:BB:GSM:TRIGger:OUTPut1:OFFTime 1
// defines the on/off ratio

// Marker delay configuration
SOURce1:BB:GSM:TRIGger:OUTPut2:DELay 1600
// delays the marker signal output

[:SOURce<hw>]:BB:GSM:TRIGger:OUTPut<ch>:MODE......................................................86
[:SOURce<hw>]:BB:GSM:TRIGger:OUTPut<ch>:ONTime................................................... 87
[:SOURce<hw>]:BB:GSM:TRIGger:OUTPut<ch>:OFFTime..................................................87
[:SOURce<hw>]:BB:GSM:TRIGger:OUTPut<ch>:PATTern................................................... 87
[:SOURce<hw>]:BB:GSM:TRIGger:OUTPut<ch>:PERiod:SLOT........................................... 87
[:SOURce<hw>]:BB:GSM:TRIGger:OUTPut<ch>:PERiod[:FRAMe].......................................88
[:SOURce<hw>]:BB:GSM:TRIGger:OUTPut<ch>:PULSe:DIVider......................................... 88
[:SOURce<hw>]:BB:GSM:TRIGger:OUTPut<ch>:PULSe[:FREQuency]?...............................88
[:SOURce<hw>]:BB:GSM:TRIGger:OUTPut<ch>:DELay......................................................89

[:SOURce<hw>]:BB:GSM:TRIGger:OUTPut<ch>:MODE <Mode>

Defines the signal for the selected marker output.
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Parameters:
<Mode> SDEF | FRAMe | SLOT | PULSe | PATTern | RATio

SDEF
As defined in slots
The marker defined in the burst editor is used.
*RST: FRAMe

Example: See Example "Marker configuration" on page 86

Manual operation: See "Marker Mode" on page 21

[:SOURce<hw>]:BB:GSM:TRIGger:OUTPut<ch>:ONTime <OnTime>
[:SOURce<hw>]:BB:GSM:TRIGger:OUTPut<ch>:OFFTime <OffTime>

Sets the duration during which the marker output is on or off.
*) If R&S SMW-B9 is installed, the minimum marker duration depends on the sample/
symbol rate.

See chapter "Basics on ..." in the R&S SMW user manual.

Parameters:
<OffTime> integer

Range: 1 (R&S SMW-B10) / 1* (R&S SMW-B9)  to 
16777215

*RST: 1

Example: See Example "Marker configuration" on page 86

Manual operation: See "Marker Mode" on page 21

[:SOURce<hw>]:BB:GSM:TRIGger:OUTPut<ch>:PATTern <Pattern>, <BitCount>

Defines the bit pattern used to generate the marker signal.

Parameters:
<Pattern> numeric

*RST: #H2

<BitCount> integer
Range: 1  to  64
*RST: 2

Example: See Example "Marker configuration" on page 86

Manual operation: See "Marker Mode" on page 21

[:SOURce<hw>]:BB:GSM:TRIGger:OUTPut<ch>:PERiod:SLOT <Slot>

Sets the repetition rate for the slot clock at the marker outputs.
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Parameters:
<Slot> integer

Range: 1  to  8
*RST: 1

Example: SOURce1:BB:GSM:TRIGger:OUTPut2:MODE SLOT
SOURce1:BB:GSM:TRIGger:OUTPut2:PERiod:SLOT 16

[:SOURce<hw>]:BB:GSM:TRIGger:OUTPut<ch>:PERiod[:FRAMe] <Frame>

Sets the repetition rate for the frame clock at the marker outputs.

Parameters:
<Frame> integer

Range: 1  to  67108863
*RST: 1

Example: SOURce1:BB:GSM:TRIGger:OUTPut2:MODE FRAM
SOURce1:BB:GSM:TRIGger:OUTPut2:PERiod:SLOT 16

[:SOURce<hw>]:BB:GSM:TRIGger:OUTPut<ch>:PULSe:DIVider <Divider>

Sets the divider for the pulsed marker signal.
*) If R&S SMW-B9 is installed, the minimum marker duration depends on the sample/
symbol rate.

See chapter "Basics on ..." in the R&S SMW user manual.

Parameters:
<Divider> integer

Range: 2 (R&S SMW-B10) / 2* (R&S SMW-B9)  to  1024
*RST: 2

Example: See Example "Marker configuration" on page 86

Manual operation: See "Marker Mode" on page 21

[:SOURce<hw>]:BB:GSM:TRIGger:OUTPut<ch>:PULSe[:FREQuency]?

Queries the pulse frequency of the pulsed marker signal PULSe.

Return values: 
<Frequency> float

Example: See Example "Marker configuration" on page 86

Usage: Query only

Manual operation: See "Marker Mode" on page 21
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[:SOURce<hw>]:BB:GSM:TRIGger:OUTPut<ch>:DELay <Delay>

Defines the delay between the signal on the marker outputs and the start of the sig-
nals.

Parameters:
<Delay> float

Range: 0  to  16777215
Increment: 0.001
*RST: 0
Default unit: Samples

Example: See Example "Marker configuration" on page 86

Manual operation: See "Marker x Delay" on page 22

5.7  Power Ramping/Slot Attenuation

[:SOURce<hw>]:BB:GSM:PRAMp:BBONly[:STATe].............................................................89
[:SOURce<hw>]:BB:GSM:PRAMp:FDELay.........................................................................89
[:SOURce<hw>]:BB:GSM:PRAMp:RDELay........................................................................ 90
[:SOURce<hw>]:BB:GSM:PRAMp:SHAPe..........................................................................90
[:SOURce<hw>]:BB:GSM:PRAMp:TIME.............................................................................91

[:SOURce<hw>]:BB:GSM:PRAMp:BBONly[:STATe] <State>

Note: This command is available for instruments with RF output only.

Selects power ramping in the baseband only or mixed power ramping in the baseband
and the RF section. The "ON" setting is mandatory if, with power ramping active, only
the baseband signal is output (I/Q outputs), or, in case of two-path instruments, if a
baseband signal is applied to two RF paths (RF A and RF B).

Only then can a signal with a defined, predictable level be output.

Parameters:
<State> 0 | 1 | OFF | ON

*RST: 0

Example: BB:GSM:PRAM:BBON ON
selects power ramping in the baseband only.

Manual operation: See " In Baseband Only " on page 44

[:SOURce<hw>]:BB:GSM:PRAMp:FDELay <FDelay>

The command sets the offset in the Falling edge of the ramp envelope at the end of a
slot. A positive value causes a ramp delay and a negative value advances the ramp.
The setting is expressed in symbols.
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Parameters:
<FDelay> float

Range: -9 Symbols  to  9 Symbols
Increment: 1 Symbol
*RST: 0 Symbols

Example: BB:GSM:PRAM:FDEL -1
Sets an advance of 1 symbol in the falling edge of the envelope
at the end of the slot.

Manual operation: See " Fall Delay " on page 43

[:SOURce<hw>]:BB:GSM:PRAMp:RDELay <RDelay>

The command sets the offset in the Rising edge of the ramp envelope at the start of a
slot. A positive value causes a ramp delay and a negative value advances the ramp.
The setting is expressed in symbols.

Parameters:
<RDelay> float

Range: -9 Symbols  to  9 Symbols
Increment: 1 Symbol
*RST: 0 Symbols

Example: BB:GSM:PRAM:RDEL -1
Sets an advance of 1 symbol in the rising edge of the envelope
at the start of the slot.

Manual operation: See " Rise Delay " on page 43

[:SOURce<hw>]:BB:GSM:PRAMp:SHAPe <Shape>

The command sets the edge shape of the ramp envelope.

Parameters:
<Shape> LINear | COSine

LINear
The transmitted power rises and falls linear fashion.
COSine
The transmitted power rises and falls in the shape of a cosine.
*RST: COSine

Example: BB:GSM:PRAM:SHAP LIN
sets a cosine-shaped rise and fall to the edge.

Manual operation: See " Ramp Function " on page 43
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[:SOURce<hw>]:BB:GSM:PRAMp:TIME <Time>

The command sets the edge slope of the ramp envelope. This specifies the number of
symbols over which the switching operation is stretched when the transmitted power is
turned on and off.

Parameters:
<Time> float

Range: 0.3 Symbols  to  16.0 Symbols
Increment: 0.1 Symbols
*RST: 5.0 Symbols

Example: BB:GSM:PRAM:TIME 6
Sets the duration of the switching operation to six symbols.

Manual operation: See " Ramp Time " on page 43

5.8  Burst Editor

[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>:TYPE...................................................92
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:USER<ch>]:LEVel... 92
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:USER<ch>]:

ATTenuation.......................................................................................................... 93
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:USER<ch>]:

SCPIRatio.............................................................................................................93
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:USER<ch>]:

FILTer:TYPE..........................................................................................................94
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:MULTislot<st0>:COUNt...........................................94
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>:VOJitter............................................... 94
[:SOURce<hw>]:BB:GSM:FOFFset:MEAN......................................................................... 95
[:SOURce<hw>]:BB:GSM:FOFFset:STANdard....................................................................95
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:USER<ch>][:

SOURce]:DATA..................................................................................................... 95
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:USER<ch>][:

SOURce]:DATA:DLISt............................................................................................ 96
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:USER<ch>][:

SOURce]:DATA:DLISt:CATalog?..............................................................................96
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:USER<ch>][:

SOURce]:DATA:PATTern........................................................................................ 97
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:MULTislot<st0>:STATe............................................ 97
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:USER<ch>]:

SFLag...................................................................................................................98
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:USER<ch>]:

SFLag:USE...........................................................................................................98
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:USER<ch>][:

SOURce]:TSC:SELect............................................................................................99
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:USER<ch>][:

SOURce]:TSC:SET................................................................................................99
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[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:USER<ch>][:
SOURce]:TSC:USER............................................................................................. 99

[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:USER<ch>]:ETSC.100
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:USER<ch>]:

ETSC:USER........................................................................................................100
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:USER<ch>]:

SYNC:SELect......................................................................................................100
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:USER<ch>]:

SYNC:USER....................................................................................................... 101
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:USER<ch>]:

FCORrection:FIXed..............................................................................................101
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:USER<ch>]:

FCORrection:FIXed:PATTern.................................................................................101
[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:USER<ch>]:

DUMMy:MIXed:PATTern?..................................................................................... 102

[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>:TYPE <Type>

Selects the burst (slot) type.

Parameters:
<Type> NORMal | HALF | EDGE | SYNC | FCORrection | DUMMy |

ACCess | ADATa | AEDGe | N16Qam | N32Qam | A16Qam |
A32Qam | HQPSk | H16Qam | H32Qam | HAQPsk | HA16Qam |
HA32Qam | NAFF | NAFH | NAHH | AAQPsk
N16Qam | N32Qam
Normal 16QAM | Normal 32QAM
HQPSk | H16Qam | H32Qam
HSR QPSK | HSR 16QAM | HSR 32QAM
NAFF | NAFH | NAHH
Normal AQPSK Full rate - Full rate | Normal AQPSK Full rate -
Half rate | Normal AQPSK Half rate - Half rate
Axxxxx (All Data)
The types All Data xxx are not defined in the standard.
*RST: NORMal

Example: BB:GSM:SLOT:TYPE DUMM
Selects dummy burst type for slot 1.

Options: Higher symbol rate mode, higher order modulation schemes
(16QAM and 32QAM) and AQPSK require R&S SMW-K41.

Manual operation: See " Burst Type " on page 45

[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>]:LEVel <Level>

The command defines the power control level of the selected slot.

Parameters:
<Level> OFF | ATT | FULL
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OFF
The slot is inactive.
ATT
The power is reduced by the amount defined
using :BB:GSM:SLOT:ATT.

FULL
Full power as specified by the level setting.
*RST: Slot 0: FULL; Slots 1...7: OFF

Example: BB:GSM:SLOT2:LEV FULL
selects power control level Full Power for slot 2.

Manual operation: See " Slot Level " on page 49

[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>]:ATTenuation <Attenuation>

The command selects one of seven possible values for the level attenuation. This
value defines by how much the power of the selected slot with power control
level :BB:GSM:SLOT:LEV ATT is reduced in relation to the normal output power
(attribute ...:LEVEL FULL). The seven possible values are set using the com-
mand :SOURce:BB:GSM:SATTenuation<n>.

Parameters:
<Attenuation> A1 | A2 | A3 | A4 | A5 | A6 | A7

Example: BB:GSM:MODE SING
Selects GSM mode Frame (Single).
BB:GSM:SLOT1:LEV ATT
Sets level attenuation mode for slot 1.
BB:GSM:SATT1 12dB
Sets the level attenuation for selection A1 to 12 dB.
BB:GSM:SLOT1:ATT A1
Sets the level attenuation for slot 0 dB to 12 dB.

Manual operation: See " Slot Attenuation " on page 49

[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>]:SCPIRatio <SCPIRatio>

The command selects one of eight possible values for the SCPIR. The eight possible
values are set using the command [:SOURce<hw>]:BB:GSM:AQPSk:SCPIR<ch0>.

Parameters:
<SCPIRatio> SCPIR7 | SCPIR6 | SCPIR5 | SCPIR4 | SCPIR3 | SCPIR2 |

SCPIR1 | SCPIR0
*RST: SCPIR0

Example: BB:GSM:AQPS:SCPIR5 -10
BB:GSM:SLOT:SUBC2:SCPIR SCPIR5

Manual operation: See "SCPIR" on page 49
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[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>]:FILTer:TYPE <Type>

Selects whether a Narrow Pulse Shape or a Wide Pulse Shape filter is used for the
selected burst type and modulation.

Parameters:
<Type> ENPShape | EWPShape

*RST: ENPShape

Example: BB:GSM:SRAT:MODE HSR
Selects higher symbol rate mode.
BB:GSM:FRAM1:SLOT1:TYPE H16Q
Selects HSR 16QAM burst type for slot 1.
BB:GSM:FRAM1:SLOT1:FILT:TYPE EWPS
Selects Wide Pulse Shape filter for slot 1.

Options: R&S SMW-K41

Manual operation: See " Filter " on page 38

[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:MULTislot<st0>:COUNt <Count>

Sets the number of slots combined in a multislot. Since multislot involves connecting
multiple slots to a single user channel, this configuration is possible for Normal (Full
Rate) bursts Normal (8PSK / EDGE) burst (SOUR:BB:GSM:FRAM:SLOT:TYPE
NORM|EDGE) and EDGE Evolution bursts.

The suffix in MULTislot defines the first slot in a multislot group. In a multiframe con-
figuration, this setting applies to the slots in all frames.

Parameters:
<Count> integer

Range: 1  to  7
*RST: 1

Example: BB:GSM:MODE SING
Selects GSM mode Frame (Single).
BB:GSM:SLOT0:TYPE NORM
Selects the NORMal burst type for slot 0.
... SLOT1 ... SLOT7
Selects burst type for slots 1 to 7 correspondingly.
BB:GSM:MULT0:COUN 8
Defines a multislot from all eight slots.
BB:GSM:MULT0:STAT ON
Switches the multislot configuration on.

Manual operation: See " Number of Slots " on page 50

[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>:VOJitter <State>

Enables/disables the simulation of a timing jitter for GMSK bursts.
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Parameters:
<State> 0 | 1 | OFF | ON

*RST: 0

Example: SOURce1:BB:GSM:FRAMe1:SLOT2:VOJitter ON
Options: R&S SMW-B14

Manual operation: See "VAMOS Offset Jitter" on page 50

[:SOURce<hw>]:BB:GSM:FOFFset:MEAN <MeanFreqOffset>

Sets the frequency offset parameter μ.

Parameters:
<MeanFreqOffset> float

Range: 0  to  9999.9
Increment: 0.1
*RST: 0

Options: R&S SMW-B14

[:SOURce<hw>]:BB:GSM:FOFFset:STANdard <StandardFreqOff>

Sets the frequency offset parameter σ.

Parameters:
<StandardFreqOff> float

Range: 0  to  9999.9
Increment: 0.1
*RST: 0

Options: R&S SMW-B14

[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>][:SOURce]:DATA <Data>

The command defines the data source for the DATA fields in the burst. This command
is valid only when burst types that contain data fields are selected. If a burst contains
multiple DATA fields, these are treated as a continuous field. For instance, data such
as a pseudo-random sequence is continued without interruption from one DATA field to
the next.

In "GSM Mode Unframed", this command defines the data source for the unframed sig-
nal. The suffix in :SLOT has to be set to 0 (BB:GSM:SLOT0:DATA).

Parameters:
<Data> ALL0 | ALL1 | PATTern | PN9 | PN11 | PN15 | PN16 | PN20 |

PN21 | PN23 | DLISt
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PNxx
The pseudo-random sequence generator is used as the data
source. There is a choice of different lengths of random
sequence.
DLISt
A data list is used. The data list is selected with the aid of com-
mand SOURce:BB:GSM:SLOT:DATA:DLISt.

ALL0 | ALL1
Internal 0 or 1 data is used.
PATTern
Internal data is used. The bit pattern for the data is defined with
the aid of command :SOURce:BB:GSM:SLOT:DATA:PATTern.

*RST: PN9

Example: BB:GSM:SLOT2:TYPE NORM
Selects NORMAL burst type for slot 2.
BB:GSM:SLOT2:DATA PN15
Selects internal PRBS data with period length 215-1 as the data
source for the DATA fields in the burst. The pseudo-random
sequence is continued without interruption from one DATA field
to the next.

Manual operation: See " Data " on page 25

[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>][:SOURce]:DATA:DLISt <DList>

The command selects a data list. This command is only valid for bursts with DATA
fields. This data list is only used if it is set as the data source with the aid of com-
mand :BB:GSM:SLOT:DATA DLIS.

Parameters:
<DList> string

Example: BB:GSM:SLOT2:TYPE NORM
selects NORMAL burst type for slot 2.
BB:GSM:SLOT2:DATA DLIS
selects internal data lists as the data source for DATA fields.
BB:GSM:SLOT2:DATA:DLIS 'test'
selects the test data list. The data list is continued without inter-
ruption from one DATA field to the next.

Manual operation: See " Data " on page 25

[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>][:SOURce]:DATA:DLISt:CATalog?

This command reads out the data list files in the default directory. The default directory
is set using command MMEM:CDIRectory. Only files with the file extension *.dm_iqd
are listed.
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Return values: 
<Catalog> string

Example: MMEM:CDIR '/var/user/temp/dlist_gsm'
Sets the default directory to /var/user/temp/dlist_gsm.
BB:GSM:SLOT2:DATA:DLIS:CAT?
Queries the available data lists in /var/user/temp/dlist_gsm.
Response: 'test_01','test_02'
Data lists test_01 and test_02 are available in /var/user/
temp/dlist_gsm.

Usage: Query only

Manual operation: See " Data for Data Field of Slot " on page 52

[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>][:SOURce]:DATA:PATTern <Pattern>, <BitCount>

Sets the data pattern for the internal data when PATTern is selected as the data
source. The length depends on the length of the data fields in the selected burst type.

Parameters:
<Pattern> numeric

*RST: #H0

<BitCount> integer
Range: 1  to  64
*RST: 1

Example: BB:GSM:SLOT2:TYPE ACC
selects the Access burst type for slot 2. This burst type contains
a 36-bit data field.
BB:GSM:SLOT2:DATA PATT
selects Pattern as the data source.
BB:GSM:SLOT2:DATA:PATT #H801FA,20
generates the data for the data field in the burst.

Manual operation: See " Data " on page 25

[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:MULTislot<st0>:STATe <State>

Switches the multislot configuration on.

The suffix in MULTislot defines the first slot in a multislot group. In a multiframe config-
uration, this setting applies to the slots in all frames.

Parameters:
<State> 0 | 1 | OFF | ON

*RST: 0

Burst Editor
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Example: BB:GSM:MODE DOUB
Selects GSM mode Frame (Double).
BB:GSM:SLOT0:TYPE NORM
Selects the NORMal burst type for slot 0.
... SLOT1 ... SLOT7
Selects burst type for slots 1 to 7 correspondingly.
BB:GSM:MULT0:COUN 8
Defines a multislot from all eight slots.
BB:GSM:MULT0:STAT ON
Switches the multislot configuration on.

Manual operation: See " Multislot Configuration " on page 50

[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>]:SFLag <SFlag>

The command sets the Stealing Flag state (only for Normal
burst :BB:GSM:SLOT:TYPE NORM).

Parameters:
<SFlag> 0 | 1

*RST: 0

Example: BB:GSM:SLOT2:TYPE NORM
selects NORMAL burst type for slot 2.
BB:GSM:SLOT2:SFL 1
sets Stealing Flags for slot 2 to the value 1.

Manual operation: See " Stealing Flag " on page 53

[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>]:SFLag:USE <Use>

The command enables or disables the use of Stealing Flags. If not used, the Stealing
Flags bits are allocated to the DATA fields (only for Normal
burst :BB:GSM:SLOT:TYPE NORM).

Parameters:
<Use> 0 | 1 | OFF | ON

*RST: ON

Example: BB:GSM:SLOT2:TYPE NORM
selects NORMAL burst type for slot 2.
BB:GSM:SLOT2:SFL 1
sets Stealing Flags for slot 2 to the value 1.
BB:GSM:SLOT2:SFL:USE ON
enables the use of Stealing Flags for slot 2.

Manual operation: See " Use Stealing Flag " on page 53
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[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>][:SOURce]:TSC:SELect <Select>

The command selects the training sequence code. The values specified in GSM 5.02
are T0...T7. When USER is selected, the value specified with the aid of
the ...:TSC:USER command described next is used.

Parameters:
<Select> T0 | T1 | T2 | T3 | T4 | T5 | T6 | T7 | USER

*RST: T0

Example: BB:GSM:MODE SING
selects Single Frame mode.
BB:GSM:SLOT2:TYPE NORM
selects Normal burst for slot 2.
BB:GSM:SLOT2:TSC:SEL T3
selects training sequence code T3 for slot 2.

Manual operation: See " TSC " on page 54

[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>][:SOURce]:TSC:SET <Set>

Sets the TSC set for the corresponding GMSK normal burst or VAMOS subchannel,
user and slot.

Parameters:
<Set> SET1 | SET2

*RST: SET1

Example: BB:GSM:SLOT2:SUBC2:USER2:TSC:SET SET2
Manual operation: See "TSC Set" on page 53

[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>][:SOURce]:TSC:USER <User>

The command specifies the user-defined training sequence code. This code is used if
the USER parameter is set with the aid of the [:SOURce<hw>]:BB:GSM[:
FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:USER<ch>][:SOURce]:TSC:
SELect command. The length is 26 bits for :BB:GSM:SLOT:TYPE NORMal and 78
bits for :BB:GSM:SLOT:TYPE EDGE.

Parameters:
<User> integer

Range: #B0,1  to  #B111 ,1...26/78 bits
*RST: #H0970897

Example: BB:GSM:SLOT3:TSC:USER #H3FFFFFF
enters the user-defined training sequence for slot 3.

Manual operation: See " TSC Pattern " on page 54
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[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>]:ETSC <Etsc>

The command selects an extended training sequence for the Synchronization burst.
There is a choice of three predefined sequences STANdard | CTS | COMPact and,
if defined, a USER sequence (only for selection of burst type :BB:GSM:SLOT:TYPE
SYNC).

Parameters:
<Etsc> STANdard | CTS | COMPact | USER

Example: BB:GSM:SLOT:TYPE SYNC
Selects Synchronization burst for slot 1.
BB:GSM:SLOT:ETSC CTS
Selects the extended training sequence CTS.

Manual operation: See " Ext Training Seq ETSC " on page 54

[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>]:ETSC:USER <User>

(only for selection of burst type :BB:GSM:SLOT:TYPE SYNC)

The command selects an extended training sequence for the Synchronization burst
USER sequence.

Parameters:
<User> integer

Example: BB:GSM:SLOT:TYPE SYNC
Selects Synchronization burst for slot 1.
BB:GSM:SLOT:ETSC USER
Selects the extended training sequence User.
BB:GSM:SLOT:ETSC:USER #H5a5a5a5a5a5a5a5a,64
Sets the ETSC.

Manual operation: See " ETSC Pattern " on page 54

[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>]:SYNC:SELect <Select>

The command selects a training sequence (SYNC sequence) for the Access burst
(only for burst type selection :BB:GSM:SLOT:TYPE ACC).

Parameters:
<Select> T0 | T1 | T2 | USER

*RST: T0

Example: BB:GSM:SLOT1:TYPE ACC
selects Access burst for slot 1.
BB:GSM:SLOT1:SYNC:SEL T1
selects Sync sequence T1.
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Manual operation: See " Training Sequence Sync " on page 54

[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>]:SYNC:USER <User>

The command outputs the bit pattern of the User Sync sequence for the Access burst.
The length is 64 bits. Superfluous bits are truncated on input. Missing bits are filled
with 0. The command is valid only for selection :BB:GSM:SLOT:SYNC:SEL USER and
for burst type selection :BB:GSM:SLOT:TYPE ACC.

Parameters:
<User> integer

Range: #B0,1  to  #B111...,41
*RST: Bit pattern from T0

Example: BB:GSM:SLOT1:TYPE ACC
selects Access burst for slot 1.
BB:GSM:SLOT1:SYNC:SEL USER
selects the User Sync sequence.
BB:GSM:SLOT1:SYNC:USER #HFFFFFFFFFF0,41
enters the User Sync sequence.

Manual operation: See " Sync Pattern " on page 55

[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>]:FCORrection:FIXed <Fixed>

The command selects the content of the FIXED field for the Frequency Correction
burst. There is a choice of two predefined sequences STANdard and COMPact and, if
defined, a USER sequence (only for burst type selection :BB:GSM:SLOT:TYPE
FCORrection).

Parameters:
<Fixed> STANdard | COMPact | USER

*RST: STANdard

Example: BB:GSM:SLOT:TYPE FCOR
selects Frequency Correction burst for slot 1.
BB:GSM:SLOT:FCOR:FIX COMP
selects content type COMPact for the Fixed field.

Manual operation: See " Fixed " on page 55

[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>]:FCORrection:FIXed:PATTern <Pattern>, <BitCount>

Sets the bit pattern of the FIXED field for the Frequency Correction burst. The length is
142 bits. Superfluous bits are truncated on input. Missing bits are filled with 0. The
command is valid only for the selection :BB:GSM:SLOT:FCOR:FIX USER and for
burst type selection :BB:GSM:SLOT:TYPE FCOR.
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Parameters:
<Pattern> numeric

*RST: #H000000000000000000000000000000000000

<BitCount> integer
Range: 142  to  142
*RST: 142

Example: BB:GSM:SLOT:TYPE FCOR
selects Synchronization burst for slot 1.
BB:GSM:SLOT:FCOR:FIX USER
selects content type USER for the Fixed field.
BB:GSM:SLOT:FCOR:FIX:PATT #B0,142
enters the content of the field.

Manual operation: See " Fixed Pattern " on page 55

[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:SUBChannel<us>][:
USER<ch>]:DUMMy:MIXed:PATTern?

This command outputs the bit pattern of the Mixed field of the Dummy burst. The con-
tents of the Mixed field is fixed and specified by the standard, the length is 142 bits.

Return values: 
<Pattern> 142 bits

Example: BB:GSM:SLOT1:TYPE DUMM
selects Dummy burst for slot 1.
BB:GSM:SLOT1:DUMM:MIX:PATT?
outputs the bit pattern of the Mixed field.
Response:

Usage: Query only

Manual operation: See " Mixed " on page 55

5.9  Slot Marker Definition

[:SOURce<hw>]:BB:GSM[:FRAMe<di>]:SLOT<st0>[:USER<ch>]:TRIGger:
OUTPut:TAG?

The command queries the content of the specified marker in the selected file.

Suffix: 
<di>

.
<di>

<st0> 0|[1] .. 7

<ch> <di>

Parameters:
<Tag> string

Slot Marker Definition
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Example: BB:GSM:FRAM:SLOT0:UER1:TRIG:OUTP:TAG? "MARKER
LIST 1"
queries the content of the marker list 1.
Response: 0:1;59:0;64:1,70:0

Usage: Query only

Manual operation: See " Configure Control Signal " on page 57
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